← Back to team overview

elementaryart team mailing list archive

Re: [Merge] lp:~xapantu/granite/fix-1020355 into lp:granite

 

Review: Needs Fixing

Hey, looks good. Just one minor issue:

24	+            set { __working = _working.visible = value; _icon.visible = !value;
25	+                    if (__working) _working.show_all();
26	+                    else _working.hide();
27	+                }
28	         }

Lines 25 and 26 seem to contain duplicate code, since "_working.visible = value" on line 24 already set the visibility. I would suggest setting the "no_show_all" property on _working and _icon before setting their "visible" property, since someone might break things by calling show_all() on a tab.
-- 
https://code.launchpad.net/~xapantu/granite/fix-1020355/+merge/113829
Your team elementaryart (old) is subscribed to branch lp:granite.


References