← Back to team overview

gnome-zeitgeist team mailing list archive

[Bug 624428] Re: GAJ-0.5.0 not running from source


After re-ordering the directory where I'm trying to run GAC from, I got
to this point:

I have a 'zeitgeist' directory with 'zeitgeist-0.5.0' and 'gnome-
activity-journal-0.5.0' in it. I perfectly run zeitgeist-daemon.py in
background, but when I try to run gnome-activity-journal from its
corresponding directory I got this message:

$ ./gnome-activity-journal 
You need Zeitgeist 0.5.0 or later for the GNOME Activity Journal to work.

So I tried to figure out the version of zeitgeist-daemon by running:
./zeitgeist-daemon --version from zeitgeist-0.5.0 directory and I got

$ ./zeitgeist-daemon --version

Can somebody explain me why my zeitgeist version is 'bzr'?

GAJ-0.5.0 not running from source
You received this bug notification because you are a member of GNOME
Zeitgeist Team, which is the registrant for GNOME Activity Journal.

Status in GNOME Activity Journal: New

Bug description:
Hi, I decided to give a try to the new version of Gnome Activity Journal (the version in lucid repositories is too old) and downloaded the sources from http://edge.launchpad.net/gnome-activity-journal/0.5.0/0.5.0/+download/gnome-activity-journal-0.5.0.tar.gz

After having zeitgeist-daemon (version 0.5.0) up-and-running I tried to launch GAJ but only got this error:

$ ./gnome-activity-journal 
./gnome-activity-journal:64: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  print "ERROR: %s." % e.message
ERROR: No module named zeitgeist.
Did you remember to fetch the 'lp:zeitgeist' and 'lp:fungtk' repositories?

Please see the README file for more information, or contact us
in IRC channel #zeitgeist on Freenode (irc.freenode.net).

Follow ups