← Back to team overview

gtg-user team mailing list archive

multiple backends fail to load on latest stable version


Hi all,

I'm using the latest stable version from the gtg ppa (ppa:gtg/ppa) on
ubuntu oneiric.

I use RTM to sync gtg across multiple computers, with good success so
far.  I haven't had much luck with this version though, and  suspect
it is due to the following error:

(I ran gtg with the -d switch)

mole@ubuntu-home-workstation:~$ gtg -d
2012-03-13 18:23:08,447 - DEBUG - gtg:core_main_init:135 - Debug output enabled.
2012-03-13 18:23:08,504 - DEBUG - __init__:__init__:68 - Backends
found: ['backend_localfile', 'backend_gnote', 'backend_launchpad',
'backend_identica', 'backend_mantis', 'backend_twitter',
2012-03-13 18:23:08,592 - WARNING - __init__:__init__:77 - Backend
backend_mantis could not be loaded: No module named suds.client
2012-03-13 18:23:08,592 - WARNING - __init__:__init__:77 - Backend
backend_twitter could not be loaded: No module named tweepy.models
2012-03-13 18:23:08,620 - DEBUG - __init__:get_backend:96 - Trying to
load backend backend_rtm, but failed!
2012-03-13 18:23:08,621 - DEBUG -
__init__:restore_backend_from_xml:144 - could not load module for
backend backend_rtm
2012-03-13 18:23:08,650 - ERROR - datastore:register_backend:431 -
Tried to register a backend without a  pid

Any suggestions on how to fix this?

Is the RTM backend currently broken?



Follow ups