← Back to team overview

hybrid-graphics-linux team mailing list archive

Re: Dumping the video BIOS


Could the problem related to that one:
The bug report is from 2009!

See also this thread here:

Regards, Stefan

2011/9/17 Stefan Dröge <stefan@xxxxxxxxxx>:
> Hi guys!
> As already mentioned in another thread, I'm a user of a Thinkpad E520
> with muxless switchable graphics. I tried to investigate what goes
> wrong when Xorg tries to use the fglrx driver and fails with the error
> message "invalid video bios signature".
> So I tried to dump the video BIOS like that:
> stefan@TE520:~$ echo 1 | sudo tee
> /sys/devices/pci0000\:00/0000\:00\:01.0/0000\:01\:00.0/rom
> stefan@TE520:~$ sudo cat
> /sys/devices/pci0000\:00/0000\:00\:01.0/0000\:01\:00.0/rom >
> vbios_ati.rom
> However this fails with the error message: "cat:
> /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/rom: Input/output
> error"
> Doing the same with the intel card works.
> So now I think: Is this the cause (i.e. the fglrx driver relies on the
> same method to read the video BIOS, but since reading the video bios
> fails, the signature is obviously wrong) or just another symptom for
> the same problem (i.e. fglrx uses another method for reading the video
> bios, that works more or less, however switchable graphics is just
> quirky and the problem is somewhere else)?
> What is your opinion? Can you replicate the problem on your system? Is
> this specific to muxless solutions / laptop brands /AMD hybrid
> solutions?
> fyi: http://smackerelofopinion.blogspot.com/2011/07/using-pci-sysfs-interface-to-dump-video.html
> Thanks, Stefan