← Back to team overview

hybrid-graphics-linux team mailing list archive

Re: AMD/AMD hybrid graphics


Well... maybe you are telling me good news...

(replying between lines)

On 13/04/14 18:06, Ruslan Kuprieiev wrote:
Hello Mario!

On 13.04.2014 22:52, Mario Mey wrote:
Hey, Ruslan, I have a dv6-3160us with the same graphic cards: 4250 and 5650. I've tried every Ubuntu version and Catalyst version and I couldn't make the 5650 works on Linux with proprietary drivers. I use Ubuntu 12.04 and Catalyst 12.04 and the 4250 works perfect (only that card). It's the way I use this computer.

I had the same problem. I wasn't able to run X with proprietary drivers, I was getting black screen and couldn't figure out what's the problem. But I've refused the idea of using old Catalyst, because it requires old X, so I wasn't able to use
other new software.

Once, I could boot on 5650 with open source drivers... but I need 3D acceleration. CONCLUSION: 5650 with open source drivers was slower than 4250 with proprietary drivers.

Did you try to use open source drivers and use DRI_PRIME <https://wiki.archlinux.org/index.php/PRIME>? It works well for me. Test with glxgears shows that 4250 gives me ~60fps and 5650 gives me ~900fps.

I have doubts about this. I just run glxgears in this computer with 4250 and proprietary drivers and have these results:

4870 frames in 5.0 seconds = 973.997 FPS
5476 frames in 5.0 seconds = 1095.111 FPS
5495 frames in 5.0 seconds = 1098.966 FPS
5494 frames in 5.0 seconds = 1098.640 FPS
5494 frames in 5.0 seconds = 1098.735 FPS
5478 frames in 5.0 seconds = 1095.528 FPS

So, if I install a new OS with DRI_PRIME... to get 900fps... so, I better stay in this configuration. I think the your computer is the same as mine.

Could you make a benchmark test with Blender? Download the last Blender version 2.7 and download this blend file: https://dl.dropboxusercontent.com/u/13242430/BLooM.blend (it's from blendswap.com). In my computer, after opening the file (maximized window) and pressing "P" (to enter in Game Engine), it starts at 20fps and, then, goes to 5fps. Then, depends on what I do with mouse and keyboard, FPS changes. What about yours?

I'm going to do the VERY LAST test installing Ubuntu 13.10 and the last version of Catalyst (13.12 and 14.3beta) and see. But I have no hope at all.

With 4250 won't work with the new versions of Catalyst. You might be not even able to simply install new drivers. Catalyst might be unable to detect 5XXX card, because default open source drivers do not turn on discrete card, so catalyst
might say that it didn't find any supported hardware.

Do you have any other information about this fucking laptop and using both cards?

I'm suffering from this laptop for a few years now. The only good solution that I
find is using Archlinux with the newest open source drivers.

Even Windows works quite bad with this stupid combination of graphics cards (yeah, thanks HP). Because of stopped support of 4XXX cards, I'm not able to make new catalyst work properly. My laptop is hell-hot with proprietary drivers.

I remember the only time I run the discrete... the fan was always on and throwing so much hot air...

On linux everything gets better and better. Every new kernel works better
than previous one(i think these hp laptops have some problems with bios too).
Also every open source driver gets better every new release.
It's the reason why I use arch, it provides the most recent soft, so my life with this
laptop becomes easier.

Yeah, next time I will be choosing my laptop much more carefully=)

So will I.

So I recommend to use the newest kernel with the newest open source ATI driver.
Then, you should turn discrete card on by using vgaswitcheroo:
# echo ON > /sys/kernel/debug/vgaswitcheroo/switch
Then, logoff and logon to restart X(don't reboot!), and then do what is told here <https://wiki.archlinux.org/index.php/PRIME>. As a result, you will be able to run 2 cards simultaneously! So X will use 4250 and
some performance-hungry, for example, game will use 5650.

If you have a better result testing the benchmark, I might try to install Arch.

I hope it will work for you. If won't, you can ask me or ask guys on the radeon irc
channel, they helped me a lot.

Ruslan Kuprieiev <kupruser@xxxxxxxxx>

Thank you!

Thanks, man.

On 24/02/14 17:48, Ruslan Kuprieiev wrote:

It works!
I've tried again with open-source drivers.
I wen't to http://dri.freedesktop.org/wiki/GalliumCompute/ and build messa.
Installed and it works perfectly!


On 24.02.2014 20:52, Ruslan Kuprieiev wrote:

I have a HP dv6 with 2 AMD cards:

[efiop@arch ~]$ lspci | grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250] 02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Madison [Mobility Radeon HD 5650/5750 / 6530M/6550M]

Did anyone try to use similar thing for OpenCL?

I've tried to use both open driver and catalyst.

With open driver, I've tried to use opencl-mesa, but any of test programs didn't work. They all end up with clGetPlatformIDs() -1001, although there was mesa.icd at /etc/OpenCL/vendors.

As for catalyst, new versions do not support my 4XXX card, but do support 5XXX one. With old drivers I didn't succeed in making X work. But, maybe I should take a better look at xorg configuration files.

The only implementation of OpenCL that do work is Intel SDK. It does run few programs using CPU, but many programs doesn't work, saying that there are no
proper devices.

If someone tried and succeeded/failed in making OpenCL work on similar hw,
please reply.

Ruslan Kuprieiev <kupruser@xxxxxxxxx>

Mailing list: https://launchpad.net/~hybrid-graphics-linux
Post to     : hybrid-graphics-linux@xxxxxxxxxxxxxxxxxxx
Unsubscribe : https://launchpad.net/~hybrid-graphics-linux
More help   : https://help.launchpad.net/ListHelp

Follow ups