← Back to team overview

kernel-packages team mailing list archive

[Bug 1194563] Re: No low battery notifications and no updated battery status (ACPI Errors


For what it's worth: I tried Linux Mint 15 MATE (on CD boot using
"compatibility mode") and it recognized the battery and also recognized
if the battery was charging or discharging (Precise does not change this
status in "Power Statistics").  BUT it also did not update the battery
charge status (stayed at the same percentage level).

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  No low battery notifications and no updated battery status (ACPI

Status in “linux” package in Ubuntu:

Bug description:
  1. I do not get warnings when the battery is low (laptop promptly
  shuts down).

  2. Battery power level is not updated. using acpi the battery power
  shows the same level present when the laptop booted - it never updates
  (if booted at 98% it will show 98% until rebooted).

  3. Battery status (on power vs on battery) functions sporadically.
  Often after an update the status will work for several boots but then
  stops working (icon only shows status when booted - ie, if cord
  plugged in, the status will not change to "on battery" if unplugged;
  it still shows that the laptop is plugged in.

  4. In power settings, "Show battery status in the menu bar" is blank.
  I can select options from the dropdown menu but they are not retained
  (when I close and reopen the settings it is blank again).

  5. Went to gconf-editor apps > gnome-power-manager and noticed that
  there is no "notify" folder/keys.

  6. Noticed that there is no gnome-power-manager.desktop in
  /etc/xdg/autostart/ (wanted to add it to autostart to see if that
  would help).  I have tried using synaptic to reinstall gnome-power-
  manager but it didn't help.

  Currently, my status (icon changes to battery/plugged in) and acpi output is:
  Battery 0: Unknown, 98% (plugged in)
  Battery 0: Discharging, 72%, 00:59:42 remaining (on battery)

  I have also added my dmesg outputs for on battery and on power
  (attached).  The laptop is an MSI-171F.  I have tried blacklisting
  msi-wmi in modprobe.d/blacklist.conf (didn't help).  Also noticed that
  etc/acpi has sevearl asus*.sh files (touchpad, keyboard backlight) in
  the folder (could that be the problem)

  Note: I currently have Jupiter enabled but have disabled/uninstalled

  before and it didn't seem to affect the behavior.
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
  ApportVersion: 2.0.1-0ubuntu17.3
  Architecture: i386
   /dev/snd/controlC0:  goonies    2074 F.... pulseaudio
   Card hw:0 'NVidia'/'HDA NVidia at 0xfae78000 irq 22'
     Mixer name	: 'Nvidia MCP79/7A HDMI'
     Components	: 'HDA:10ec0888,146271f0,00100101 HDA:10573055,00305557,00100900 HDA:10de0007,10de0101,00100100'
     Controls      : 49
     Simple ctrls  : 25
  DistroRelease: Ubuntu 12.04
  HibernationDevice: RESUME=UUID=09bc9ef7-ee94-4118-9e7a-62781fcbe7a5
  InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
   Bus 002 Device 002: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse
   Bus 001 Device 003: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: Micro-Star International MS-171F
  MarkForUpload: True
  NonfreeKernelModules: nvidia
  Package: linux (not installed)
   PATH=(custom, no user)
  ProcFB: 0 VESA VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-34-generic root=UUID=61f0eab4-62c9-43d9-a603-4f283d1717de ro quiet splash acpi_enforce_resources=lax vt.handoff=7
  ProcVersionSignature: Ubuntu 3.5.0-34.55~precise1-generic
   linux-restricted-modules-3.5.0-34-generic N/A
   linux-backports-modules-3.5.0-34-generic  N/A
   linux-firmware                            1.79.4
   0: phy0: Wireless LAN
   	Soft blocked: no
   	Hard blocked: no
  Tags:  precise
  Uname: Linux 3.5.0-34-generic i686
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
  dmi.bios.date: 12/05/2008
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: A171FIZT V1.05
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: MS-171F
  dmi.board.vendor: Micro-Star International
  dmi.board.version: Ver 1.000
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 10
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrA171FIZTV1.05:bd12/05/2008:svnMicro-StarInternational:pnMS-171F:pvrVer1.000:rvnMicro-StarInternational:rnMS-171F:rvrVer1.000:cvnToBeFilledByO.E.M.:ct10:cvrToBeFilledByO.E.M.:
  dmi.product.name: MS-171F
  dmi.product.version: Ver 1.000
  dmi.sys.vendor: Micro-Star International

To manage notifications about this bug go to: