← Back to team overview

kernel-packages team mailing list archive

[Bug 1203565] Re: 045e:009c Microsoft Keyboard Elite for Bluetooth dead keys problem


Hi !

I've just tested with Saucy live cd and the dongle is recognized on lsusb, but doesn't appear on the bluetooth software, which cannot activate the bluetooth of course.
Then the keyboard doesn't work at all (neither the mouse) with Saucy.

I made another interesting test : I put my dongle and keyboard on
another computer, which have the same version of Ubuntu like me and an
Asus H87I-Plus which is socket 1150 Haswell, too.

With bluez v4.98 by default on Ubuntu Precise 12.04, it's the same way as my computer (keyboard paired but impossible to activate).
Then I tried to do the same way : uninstalling the 4.98 and installing the 4.60 of bluez.

Result : keyboard paired, and same problem : dead keys doesn't work

I'll try to test another live-cd of another linux distribution which have same kernel version and if possible same bluez version (4.98 or 4.60).
An idea of which distribution to choose ?

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  045e:009c Microsoft Keyboard Elite for Bluetooth dead keys problem

Status in “linux” package in Ubuntu:

Bug description:
  In Precise with 4.60 version of bluez I can pair my keyboard and mouse

  === The problem is that dead keys of my keyboard (I mean -L or R-
  CTRL, ALT, SUPER, -L or R- SHIFT, ALT-GR) doesn't work ANYMORE
  (whether application I opened, console included). I say anymore
  because it works with older motherboard. The new motherboard is an
  1150 Haswell one from Asus.

  What I can say is :
  1/ When booting, my BIOS recognize perfectly the dead keys of my keyboard, meaning that the bluetooth dongle or the motherboard is not directly concerned.
  2/ When doing a second installation of Ubuntu, same problem.
  3/ When trying the option 'keyboard layout' (whatever layout I choose), I don't see those dead keys flashing, meaning the system doesn't react at all when pressing them.
  4/ By chance, I found another keyboard (same model, same brand), same problem, meaning the keyboard is not concerned (it works on the older motherboard, then it was poor chance that the keyboard broked just before reinstalling).
  5/ Tried the setxkbmap command (with sudo or without), nothing's better
  6/ Tried the xmodmap command, I see the 0x codes for Left SHIFT, all dead keys are there (see attachment)
  7/ Normal keyboard (no wireless) works perfectly
  8/ Put the dongle on an other usb slot doesn't change anything
  9/ Command xev doesn't makes changes when pressing dead keys.

  For me it's clearly a Ubuntu's system bug, with my motherboard (Asus
  H87-PRO socket 1150).

  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.25.
  ApportVersion: 2.0.1-0ubuntu17.3
  Architecture: amd64
   /dev/snd/pcmC0D0p:   syl        4375 F...m rhythmbox
  CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
   Card hw:0 'PAD'/'RME Digi96/8 PAD at 0xf4000000, irq 19'
     Mixer name	: ''
     Components	: ''
     Controls      : 10
     Simple ctrls  : 6
   Card hw:1 'NVidia'/'HDA NVidia at 0xf3080000 irq 17'
     Mixer name	: 'Nvidia GPU 14 HDMI/DP'
     Components	: 'HDA:10de0014,10de0101,00100100'
     Controls      : 24
     Simple ctrls  : 4
   Card hw:2 'NVidia_1'/'HDA NVidia at 0xe3080000 irq 16'
     Mixer name	: 'Nvidia GPU 0a HDMI/DP'
     Components	: 'HDA:10de000a,10de0101,00100100'
     Controls      : 24
     Simple ctrls  : 4
  DistroRelease: Ubuntu 12.04
  MachineType: ASUS All Series
  MarkForUpload: True
  NonfreeKernelModules: nvidia
  Package: linux (not installed)
  ProcFB: 0 VESA VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-36-generic root=UUID=d2f8f163-a1ee-4332-a910-d593309cd2a6 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.5.0-36.57~precise1-generic
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-3.5.0-36-generic N/A
   linux-backports-modules-3.5.0-36-generic  N/A
   linux-firmware                            1.79.4
   0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
  Tags:  precise running-unity
  Uname: Linux 3.5.0-36-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm audio bluetooth boinc cdrom dip lp lpadmin netdev plugdev sambashare scanner sudo video
  dmi.bios.date: 04/08/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 0501
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: H87-PRO
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0501:bd04/08/2013:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnH87-PRO:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: All Series
  dmi.product.version: System Version
  dmi.sys.vendor: ASUS

To manage notifications about this bug go to: