← Back to team overview

kernel-packages team mailing list archive

[Bug 1079440] Re: i945: Random complete freeze using dual monitors


I believe I'm also experiencing this bug on my Asus Eee PC 1015PEM which
appears to be using an Intel i915 graphics chip (at least that is the
driver thats dmesg says is loaded). As described above this works fine
when using the laptops build in screen and no external monitor.
Attaching an external monitor will provide a usable display for an
unpredictable amount of time before a freeze will happen.

Most of the time the freeze will still allow the mouse pointer to move
and also allow CTRL + ALT + F1 to bring up the console. Sometimes
neither the mouse moves or the console can be brought up.

I've tried using the taskset workaround but this has not worked for me.
This is still a bug using 13.04 with the latest updates installed
(kernel 3.8.0-27-generic).

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  i945: Random complete freeze using dual monitors

Status in The Linux Kernel:
  Fix Released
Status in “linux” package in Ubuntu:

Bug description:
  I can run all day without problems if I boot up using just the laptop
  screen, but using an external monitor to extend the viewing area I get
  a crash after about an hour or two of use, 100% guaranteed.  It seems
  completely random.  I was getting similar crashes in 12.04 but using
  2d "fixed" that.  Now with 12.10 I have to use 3d.  By complete freeze
  I mean no mouse click or key press does anything but I can still see
  the cursor move with the mouse.

  When I first installed 12.10 and the system froze I could use ctrl-
  alt-F1 to restart the display manager, but since a recent system
  update ctrl-alt-F1 just switches to a black screen (no text).  Typing
  any kind of command seems to have no effect, so it is more than the
  characters simply not displaying.  So this recent system update seems
  to make the crash more severe when it happens.

  Description:	Ubuntu 12.10
  Release:	12.10

    Installed: 1:
    Candidate: 1:
    Version table:
   *** 1: 0
          500 http://us.archive.ubuntu.com/ubuntu/ quantal-updates/main amd64 Packages
          100 /var/lib/dpkg/status
       1: 0
          500 http://us.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: compiz 1:
  ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
  Uname: Linux 3.5.0-18-generic x86_64
  ApportVersion: 2.6.1-0ubuntu6
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  Date: Thu Nov 15 14:13:02 2012
  DistUpgraded: Fresh install
  DistroCodename: quantal
  DistroVariant: ubuntu
  DkmsStatus: vboxhost, 4.2.4, 3.5.0-18-generic, x86_64: installed
  EcryptfsInUse: Yes
   Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03) (prog-if 00 [VGA controller])
     Subsystem: Dell Device [1028:01cd]
     Subsystem: Dell Device [1028:01cd]
  InstallationDate: Installed on 2012-10-31 (15 days ago)
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
  MachineType: Dell Inc. MP061
  MarkForUpload: True
  PackageArchitecture: all
   PATH=(custom, no user)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-18-generic root=UUID=0650f48a-9821-4f03-aad9-130f0ff78d65 ro quiet splash vt.handoff=7
  SourcePackage: compiz
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/18/2006
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A06
  dmi.board.name: 0FF049
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvrA06:bd12/18/2006:svnDellInc.:pnMP061:pvr:rvnDellInc.:rn0FF049:rvr:cvnDellInc.:ct8:cvr:
  dmi.product.name: MP061
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.39-0ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

To manage notifications about this bug go to: