← Back to team overview

kernel-packages team mailing list archive

[Bug 1159418] Re: [SONY Vaio SVZ1311C5E] plug and play with thunderbolt devices was working with 3.5 but is still not working with 3.8


** Summary changed:

- plug and play with thunderbolt devices was working with 3.5 but is still not working with 3.8
+ [SONY Vaio SVZ1311C5E] plug and play with thunderbolt devices was working with 3.5 but is still not working with 3.8

** Tags added: latest-bios-r0092c6 regression-release

** Tags added: cherry-pick

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [SONY Vaio SVZ1311C5E] plug and play with thunderbolt devices was
  working with 3.5 but is still not working with 3.8

Status in “linux” package in Ubuntu:

Bug description:

  I'm running a kubuntu raring on a sony vaio z series (svz1311c5e) and
  I also have the sony docking station.

  With the linux-kernel-3.5 I can have plug and play working with every
  devices of the docking station but upgrading to 3.8 the plug and play
  is still not working. If I connect the docking station before turning
  on the computer everithing works  but if I disconnect and reconnect it
  again every device in the docking station doesn't work.

  The docking station is connected through light peak (thunderbolt).
  Using the kernel 3.5 I can unplug and plug in the docking and every devices will be refreshed, except the usb hub which is still not working.  With the version 3.8 if I plug the docking station after the boot every device of the docking station doesn't work.

  Anyway everything works fine if I plug in the docking station before
  the boot.

  The plug and play of those devices doesn't work also with every
  vanilla kernel, so I think it's a patch introduced by ubuntu in the
  kernel version 3.5.

  In order to assure the support for every new vaio I suggest to include
  in your kernels also the last version of the module sony-laptop. This
  module is already included in main line but the version is outdated
  and several things don't work. I asked to the maintainer about that
  and he said that the module will be upgraded as soon as he can find
  the enough time to rewrite it in an acceptable way. Anyway the version
  provided by his git seems to be stable, or at least I had no problems
  with that.

  I suggest to include the last version of this module under the ubuntu
  kernel packages. You can find the last version here:

  Thank you for your support
  ApportVersion: 2.9.2-0ubuntu2
  Architecture: amd64
   /dev/snd/controlC1:  diego      8182 F.... pulseaudio
   /dev/snd/controlC0:  diego      8182 F.... pulseaudio
  DistroRelease: Ubuntu 13.04
  InstallationDate: Installed on 2013-02-24 (27 days ago)
  InstallationMedia: Kubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.1)
  MachineType: Sony Corporation SVZ1311C5E
  MarkForUpload: True
  Package: linux (not installed)
   0 inteldrmfb
   1 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-13-generic root=/dev/mapper/kubuntu-root ro i915.i915_enable_rc6=1 pcie_aspm=force drm.vblankoffdelay=1 i915.lvds_downclock=1 i915.semaphores=1 quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.8.0-13.23-generic 3.8.3
   linux-restricted-modules-3.8.0-13-generic N/A
   linux-backports-modules-3.8.0-13-generic  N/A
   linux-firmware                            1.104
  Tags:  raring
  Uname: Linux 3.8.0-13-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  dmi.bios.date: 05/21/2012
  dmi.bios.vendor: Insyde Corp.
  dmi.bios.version: R0092C6
  dmi.board.asset.tag: N/A
  dmi.board.name: VAIO
  dmi.board.vendor: Sony Corporation
  dmi.board.version: N/A
  dmi.chassis.asset.tag: N/A
  dmi.chassis.type: 10
  dmi.chassis.vendor: Sony Corporation
  dmi.chassis.version: N/A
  dmi.modalias: dmi:bvnInsydeCorp.:bvrR0092C6:bd05/21/2012:svnSonyCorporation:pnSVZ1311C5E:pvrJ004RUQP:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
  dmi.product.name: SVZ1311C5E
  dmi.product.version: J004RUQP
  dmi.sys.vendor: Sony Corporation

To manage notifications about this bug go to: