← Back to team overview

kernel-packages team mailing list archive

[Bug 1168967] Re: [Lenovo ThinkPad T500 2055] regression: no video after upgrading kernel, mesa, libc, and several other packages


Greg Ward, would you need a backport to a release prior to Raring, or
may we close this as Status Invalid?

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [Lenovo ThinkPad T500 2055] regression: no video after upgrading
  kernel, mesa, libc, and several other packages

Status in “linux” package in Ubuntu:

Bug description:
  Steps to reproduce:
  1) on 2013-03-31, shutdown laptop for a 2-week vacation
  2) on 2013-04-13, return from vacation, boot laptop, and apply pending updates with update-manager
  3) reboot laptop

  Expected result: Ubuntu boots just as it did before the update (it
  worked fine on 2013-03-31, and then again on 2013-04-13 before the

  Actual result: no video (black screen) -- no splash screen, no kernel
  log messages (which are normally suppressed anyways), no login screen,
  nothing. Just blackness.

  This is a Lenovo ThinkPad T500, which is slightly unusual in that it
  has two video chipsets, one nVIDIA and one ATI. I'm quite sure I
  disabled the nVIDIA chipset in the BIOS for the obvious reason that
  nVIDIA + Linux = pain. (But I did this when I bought the laptop in Sep
  2012, and have not checked the BIOS settings recently. Will do that

  If I boot into recovery mode, things are a bit different. For
  starters, I get the traditional kernel boot logs that are normally
  suppressed by Ubuntu, but they're all in 80x25 text mode (I'm used to
  seeing a high-res text console, presumably at the screen's native
  resolution). Then I get the "Recovery Menu". The "root" option works
  as expected, i.e. I get a root shell in 80x25 text mode. If I select
  "failsafeX", at least X starts with a warning dialog: "The system is
  running in low-graphics mode". That's as far as I get; the failsafeX
  mode appears to have several unrelated bugs, which I'll report

  From /var/lib/dpkg.log, I believe the list of packages upgraded by the
  bad update on 2013-04-13 was:

    libjack-jackd2-0:i386 1.9.8~dfsg.4+20120529git007cdc37-2ubuntu2
    libjack-jackd2-0:amd64 1.9.8~dfsg.4+20120529git007cdc37-2ubuntu2
    libc-bin:amd64 2.15-0ubuntu20
    man-db:amd64 2.6.3-1
    desktop-file-utils:amd64 0.20-0.1ubuntu1
    gnome-menus:amd64 3.6.0-0ubuntu1
    bamfdaemon:amd64 0.3.4-0ubuntu1
    update-notifier-common:all 0.126
    ureadahead:amd64 0.100.0-12build1
    libavutil51:amd64 6:0.8.6-0ubuntu0.12.10.1
    libavcodec53:amd64 6:0.8.6-0ubuntu0.12.10.1
    libavformat53:amd64 6:0.8.6-0ubuntu0.12.10.1
    mesa-common-dev:amd64 9.0.3-0ubuntu0.1
    libglapi-mesa:amd64 9.0.3-0ubuntu0.1
    libgl1-mesa-glx:amd64 9.0.3-0ubuntu0.1
    libgl1-mesa-dev:amd64 9.0.3-0ubuntu0.1
    libgl1-mesa-dri:amd64 9.0.3-0ubuntu0.1
    libpoppler28:amd64 0.20.4-0ubuntu1.2
    libpoppler-glib8:amd64 0.20.4-0ubuntu1.2
    libpostproc52:amd64 6:0.8.6-0ubuntu0.12.10.1
    libswscale2:amd64 6:0.8.6-0ubuntu0.12.10.1
    libxatracker1:amd64 9.0.3-0ubuntu0.1
    libxslt1.1:amd64 1.1.26-14ubuntu0.1
    linux-image-3.5.0-27-generic:amd64 3.5.0-27.46
    firefox:amd64 20.0+build1-0ubuntu0.12.10.3
    firefox-globalmenu:amd64 20.0+build1-0ubuntu0.12.10.3
    firefox-gnome-support:amd64 20.0+build1-0ubuntu0.12.10.3
    firefox-locale-en:amd64 20.0+build1-0ubuntu0.12.10.3
    libufe-xidgetter0:amd64 2.4.4-0ubuntu0.2
    xul-ext-unity:all 2.4.4-0ubuntu0.2
    linux-image-extra-3.5.0-27-generic:amd64 3.5.0-27.46
    linux-headers-3.5.0-27:all 3.5.0-27.46
    linux-headers-3.5.0-27-generic:amd64 3.5.0-27.46
    linux-libc-dev:amd64 3.5.0-27.46
    poppler-utils:amd64 0.20.4-0ubuntu1.2
    thunderbird:amd64 17.0.5+build1-0ubuntu0.12.10.1
    thunderbird-globalmenu:amd64 17.0.5+build1-0ubuntu0.12.10.1
    thunderbird-locale-en:amd64 1:17.0.5+build1-0ubuntu0.12.10.1
    thunderbird-gnome-support:amd64 17.0.5+build1-0ubuntu0.12.10.1
    thunderbird-locale-en-us:all 1:17.0.5+build1-0ubuntu0.12.10.1
    xdiagnose:all 3.2.3
    libc-bin:amd64 2.15-0ubuntu20

  (I just grep'ed for "status: installed" in /var/lib/dpkg.log.)

  I don't think the kernel is at fault: I've tried booting into recovery
  mode with 3.5.0-26 (which was running before the update) and 3.5.0-21
  (the oldest kernel still on this machine, from Dec 2012) and got the
  exact same behaviour.

  I don't think mesa is at fault: I dug up the 9.0 packages (shipped
  with 12.10 release), downgraded to them, and still have the same
  behaviour. (The actual upgrade from was mesa 9.0.2 to 9.0.3, but I
  couldn't find the 9.0.2 packages on archive.ubuntu.com.)

  I haven't tried downgrading any of the other upgraded packages. If
  anyone can suggest likely candidates to downgrade first, I'm all ears.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: xorg 1:7.7+1ubuntu4
  ProcVersionSignature: Ubuntu 3.5.0-27.46-generic
  Uname: Linux 3.5.0-27-generic x86_64
  ApportVersion: 2.6.1-0ubuntu10
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  Date: Sun Apr 14 16:38:04 2013
  DistUpgraded: 2012-11-22 16:59:36,329 ERROR got error from PostInstallScript ./xorg_fix_proprietary.py (Failed to execute child process "./xorg_fix_proprietary.py" (No such file or directory))
  DistroCodename: quantal
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes
   Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
     Subsystem: Lenovo Device [17aa:2115]
   Advanced Micro Devices [AMD] nee ATI RV635 [Mobility Radeon HD 3650] [1002:9591] (prog-if 00 [VGA controller])
     Subsystem: Lenovo Device [17aa:2116]
  InstallationDate: Installed on 2012-09-30 (196 days ago)
  InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
  MachineType: LENOVO 20552CU
  MarkForUpload: True
   Socket 0:
     no product info available
   Socket 0:
     no card
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-27-generic root=UUID=92edda48-9aa3-4a68-8cea-d57fa7ca469a ro recovery nomodeset
  SourcePackage: xorg
  UpgradeStatus: Upgraded to quantal on 2012-11-22 (142 days ago)
  dmi.bios.date: 12/14/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 6FET92WW (3.22 )
  dmi.board.name: 20552CU
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: dmi:bvnLENOVO:bvr6FET92WW(3.22):bd12/14/2011:svnLENOVO:pn20552CU:pvrThinkPadT500:rvnLENOVO:rn20552CU:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 20552CU
  dmi.product.version: ThinkPad T500
  dmi.sys.vendor: LENOVO
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.39-0ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 9.0-0ubuntu1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 9.0-0ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.13.0-0ubuntu6.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120913.8637f772-0ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.9-0ubuntu2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.2-0ubuntu3

To manage notifications about this bug go to: