← Back to team overview

kernel-packages team mailing list archive

[Bug 1179774] Re: ipmi kernel modules not detecting OCPv3 AMD Roadrunner BMC


I tried the precise daily build (08-Aug-2013) which had the kernel 3.8.0-27-generic #40 for the installer... then after I rebooted 3.8.0-28-generic #41 was installed.

uname -a suggests the installer kernel was built/compiled on Fri Jul

Anyway, the BMC did not work (ipmitool lan print).  I used the script
above to manually load it... and then, quite annoyingly, when I rebooted
to capture logs and output, it just worked.....

I'm not sure if the problem is intermittent or not... so will do some
additional desting

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  ipmi kernel modules not detecting OCPv3 AMD Roadrunner BMC

Status in Open Compute Project:
Status in “linux” package in Ubuntu:

Bug description:
  In order for the ipmi kernel modules to work on the OCPv3 AMD
  Roadrunner machine I need to run the attached script.

  Here is the output of the device information:

  test@precise2:~$ PCIADDRESS=`lspci | grep 16b9 | awk '{print $1}'`

  test@precise2:~# echo "BMC PCI Address is "$PCIADDRESS
  BMC PCI Address is 02:00.6

  test@precise2:~$ lspci -s $PCIADDRESS -vvv 
  02:00.6 IPMI SMIC interface: Broadcom Corporation Device 16b9 (prog-if 01)
  	Subsystem: Broadcom Corporation Device 96b9
  	Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
  	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
  	Region 0: Memory at d0010000 (64-bit, prefetchable) [size=64K]
  	Region 2: Memory at d0000000 (64-bit, prefetchable) [size=64K]
  	Capabilities: <access denied>
  	Kernel driver in use: ipmi_si
  	Kernel modules: ipmi_si

To manage notifications about this bug go to: