← Back to team overview

kernel-packages team mailing list archive

[Bug 1201092] Re: Cannot load kvm_amd module - (says disabled by bios)



first of all I have AMD E-350D, you have AMD E-350. 
I don't know what the "D" stands for, but we don't have the same identical CPU.

I give you the feedback from the kernel developers and from the MainBoard vendor.
I had already tried the above command (rdmsr....). It says "1" ... DISABLED.
Another thing - important - VirtualBox behavior is misleading: it lets you check the flag to enable the AMD-V extension, but looking at logs, it seems that the extension is not being loaded. 

Therefore, there are two possiblities.
Kernel developers say: it may be a bug in the BIOS. 
The vendor (GygaByte) says: it's a problem with Linux kernel. 

BTW, I can understand that everybody says that it's someone else fault, but I can't understand that GigaByte asks me to install windows and test it over windows. 
Right now I am stuck as I have a spare partition starting after 1.7GB and windows doesn't want to install on such partition.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Cannot load kvm_amd module - (says disabled by bios)

Status in “kvm” package in Ubuntu:
Status in “linux” package in Ubuntu:
Status in “linux” package in Fedora:

Bug description:
  - Firt of all I would like to mention that this bug as been also raised for Fedora 18.
  Here is the link: https://bugzilla.redhat.com/show_bug.cgi?id=978608

  - I am running Ubuntu Raring (with the kernel 3.8.0-27-generic), but
  NOTE that I've also tried the new kernel 3.10 from Ubuntu Saucy.

  - It happens with the following CPU: AMD E-350D

  - The kvm-ok executable says that the system is capable of running
  KVM, but it also says the it's disabled in the BIOS.

  - This is the out put of kvm-ok:
  # kvm-ok
  INFO: /dev/kvm does not exist
  HINT:   sudo modprobe kvm_amd
  INFO: Your CPU supports KVM extensions
  INFO: KVM (svm) is disabled by your BIOS
  HINT: Enter your BIOS setup and enable Virtualization Technology (VT),
        and then hard poweroff/poweron your system
  KVM acceleration can NOT be used

  - This is what modprobe kvm-amd says:
  # modprobe kvm-amd
  ERROR: could not insert 'kvm_amd': Operation not supported
  root@yasna:~# dmesg |tail -n1
  [ 2542.263745] kvm: disabled by bios

  ApportVersion: 2.9.2-0ubuntu8.3
  Architecture: amd64
   /dev/snd/controlC1:  lightdm    2472 F.... pulseaudio
   /dev/snd/controlC0:  lightdm    2472 F.... pulseaudio
  CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
  DistroRelease: Ubuntu 13.04
  HibernationDevice: RESUME=UUID=3addb1e2-6fd3-4581-b4e3-287fc638926d
  InstallationDate: Installed on 2013-07-02 (12 days ago)
  InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
  MachineType: Gigabyte Technology Co., Ltd. To be filled by O.E.M.
  MarkForUpload: True
  NonfreeKernelModules: fglrx
  Package: linux
  PackageArchitecture: amd64
  ProcFB: 0 VESA VGA
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.8.0-27-generic root=UUID=a820e9a0-4b2c-4ab6-adfd-f638f44d867f ro rootflags=subvol=@ quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.8.0-27.40-generic
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-3.8.0-27-generic N/A
   linux-backports-modules-3.8.0-27-generic  N/A
   linux-firmware                            1.106
   0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
  Tags: raring package-from-proposed third-party-packages
  Uname: Linux 3.8.0-27-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)


  dmi.bios.date: 01/18/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F3
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: E350N WIN8
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF3:bd01/18/2013:svnGigabyteTechnologyCo.,Ltd.:pnTobefilledbyO.E.M.:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnE350NWIN8:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: To be filled by O.E.M.
  dmi.product.version: To be filled by O.E.M.
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.

To manage notifications about this bug go to: