← Back to team overview

kernel-packages team mailing list archive

[Bug 1096989] Re: 10ec:8179 No wireless support for Lenovo IdeaCentre Q190 (RTL8188E)


Rick D, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies
Ubuntu Community: https://wiki.ubuntu.com/ReportingBugs

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being
addressed as quickly as possible.

No need exists to comment here at this time. If you have further
questions, you are welcome to redirect them to the appropriate mailing
list or forum via http://www.ubuntu.com/support/community/mailinglists ,
or you may contact me directly.

Thank you for your understanding.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  10ec:8179 No wireless support for Lenovo IdeaCentre Q190 (RTL8188E)

Status in HWE Next Project:
Status in The Linux Kernel:
Status in “linux” package in Ubuntu:

Bug description:
  I'm on 12.10. The wifi adapter doesn't seem to be recognized at all:
  doesn't show up in NetworkManager, no adapter listed by iwconfig. The
  wifi card seems to be a RTL8188E (lspci -nn tells me it's 10ec:8179).

  I've tried to:
     - install the Realtek driver for the RTL8188CE (seemed close enough...)
     - install the driver from https://github.com/tianon/linux-rtlwifi-8188ce
     - install linux-backports-modules-cw
     - upgrade to kernel 3.7

  None of those worked.

  ApportVersion: 2.6.1-0ubuntu10
  Architecture: amd64
   /dev/snd/controlC0:  cat        1782 F.... pulseaudio
  CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
  DistroRelease: Ubuntu 12.10
  HibernationDevice: RESUME=UUID=b597ccff-c6a0-4caf-8d7a-86b5885c2e71
  InstallationDate: Installed on 2013-01-07 (29 days ago)
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
   eth0      no wireless extensions.

   lo        no wireless extensions.
  MachineType: LENOVO 10115
  MarkForUpload: True
  Package: linux (not installed)
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-23-generic root=UUID=181643fb-824f-49b7-bad9-b8a31c74a430 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.5.0-23.35-generic
   linux-restricted-modules-3.5.0-23-generic N/A
   linux-backports-modules-3.5.0-23-generic  N/A
   linux-firmware                            1.95

  Tags:  quantal running-unity
  Uname: Linux 3.5.0-23-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  dmi.bios.date: 09/21/2012
  dmi.bios.vendor: LENOVO
  dmi.bios.version: EZKT12AUS
  dmi.board.name: INVALID
  dmi.board.vendor: LENOVO
  dmi.board.version: Win8 STD MM DPK IPG
  dmi.chassis.type: 3
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnLENOVO:bvrEZKT12AUS:bd09/21/2012:svnLENOVO:pn10115:pvrIdeaCentreQ190:rvnLENOVO:rnINVALID:rvrWin8STDMMDPKIPG:cvnLENOVO:ct3:cvrChassisVersion:
  dmi.product.name: 10115
  dmi.product.version: IdeaCentre Q190
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: