← Back to team overview

kernel-packages team mailing list archive

[Bug 1170885] Re: Samsung Laptop support module doesn't load for Samsung NP900X3C-A06AU


If I understand correctly, the module samsung-laptop can't be loaded in
EFI mode. And this is "by choice". Are there any plans to support UEFI
mode? Is anyone working on this or it will never be resolved? Thanks!

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Samsung Laptop support module doesn't load for Samsung NP900X3C-A06AU

Status in “linux” package in Ubuntu:

Bug description:
  Similarly to Bug #1012284 "Samsung Laptop support module refuse to
  load for Samsung 900X3C" I'm trying to load "samsung_laptop" in to the
  kernel so that I can access functionality provided under
  /sys/devices/platform/samsung (like keyboard backlight control).

  When doing a modprobe I get "No such device":
  # modprobe samsung-laptop 
  FATAL: Error inserting samsung_laptop (/lib/modules/3.5.0-27-generic/kernel/drivers/platform/x86/samsung-laptop.ko): No such device

  I also tried a mainline build, as per https://wiki.ubuntu.com/KernelMainlineBuilds , and got the same result:
  # modprobe samsung-laptop 
  FATAL: Error inserting samsung_laptop (/lib/modules/3.9.0-999-generic/kernel/drivers/platform/x86/samsung-laptop.ko): No such device
  # uname -a
  Linux sammy.lyte 3.9.0-999-generic #201304190456 SMP Fri Apr 19 08:57:39 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

  I'm not sure if this is a regression from the previous fix or simply
  slightly different hardware.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: linux-image-generic
  ProcVersionSignature: Ubuntu 3.5.0-27.46-generic
  Uname: Linux 3.5.0-27-generic x86_64
  ApportVersion: 2.6.1-0ubuntu10
  Architecture: amd64
   /dev/snd/controlC0:  dschoen    2693 F.... pulseaudio
  CRDA: Error: [Errno 2] No such file or directory: 'iw'
  Date: Sat Apr 20 15:12:20 2013
  HibernationDevice: RESUME=UUID=de097eb6-c8eb-47b8-b020-f209468bcb36
  InstallationDate: Installed on 2012-12-10 (130 days ago)
  InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
  MachineType: SAMSUNG ELECTRONICS CO., LTD. 900X3C/900X3D/900X4C/900X4D
  MarkForUpload: True
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-27-generic root=/dev/mapper/sammy-root ro rootflags=subvol=@
   linux-restricted-modules-3.5.0-27-generic N/A
   linux-backports-modules-3.5.0-27-generic  N/A
   linux-firmware                            1.95
  SourcePackage: linux
  UpgradeStatus: Upgraded to quantal on 2013-03-09 (42 days ago)
  dmi.bios.date: 09/19/2012
  dmi.bios.vendor: Phoenix Technologies Ltd.
  dmi.bios.version: P02ABK
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: NP900X3C-A06AU
  dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.board.version: FAB1
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.chassis.version: 0.1
  dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvrP02ABK:bd09/19/2012:svnSAMSUNGELECTRONICSCO.,LTD.:pn900X3C/900X3D/900X4C/900X4D:pvr0.1:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP900X3C-A06AU:rvrFAB1:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvr0.1:
  dmi.product.name: 900X3C/900X3D/900X4C/900X4D
  dmi.product.version: 0.1
  dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

To manage notifications about this bug go to: