← Back to team overview

kernel-packages team mailing list archive

[Bug 1413149] Re: rtsx_usb_ms: system load immediately climbs, and stays above 1.00


I reviewed the Ubuntu kernel team e-mail thread.
I do not understand why the bug patch submitted upstream on November 6th seems to have stalled.
I did observe that there wasn't an "ACK", that I could find.
So I wondered of the patch had been modified or another solution was found.
Is there any way to check the status of upstream patch requests?
(by the way, I asked these same questions on IRC, but it was suggest by apw that this bug report submission was the preferred way to proceed.)

Reference: http://irclogs.ubuntu.com/2015/01/20/%23ubuntu-

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  rtsx_usb_ms: system load immediately climbs, and stays above 1.00

Status in linux package in Ubuntu:
  In Progress
Status in linux source package in Utopic:
  In Progress
Status in linux package in Debian:
  Fix Released

Bug description:
  SRU Justification:
  Users of devices that use the rtsx_usb_ms module will experience false load values due to an issue in this driver.
  [Test Case]
  Boot computer and monitor load levels.
  This patch by Ben Hutchings: https://lkml.org/lkml/2014/11/5/905
  Has been applied to Debian/3.16, and has been posted upstream.


  I'm running 64 bit ubuntu 14.10 on an Asus  N550JK-DB74T laptop.  When
  I startup Ubuntu the system load climbs to 1.00 within a minute, and
  it never goes below 1.00 again, despite my processor being idle.  This
  behavior occurs in all the newer kernels I installed from
  http://kernel.ubuntu.com/~kernel-ppa/mainline/  but when I installed
  the kernel from ubuntu 14.04, as well when I ran the ubuntu 14.04 from
  a usb the load average behaved normally, so the bug must have started
  in either kernel 3.15 or 3.16.

  When I posted this to ubuntu forums, a very helpful person able to
  point me to this bug report: https://bugs.debian.org/cgi-
  bin/bugreport.cgi?bug=765717 and to this  submitted patch
  https://lkml.org/lkml/2014/11/5/905 .  When I applied that patch to
  kernel 3.16 my issue was solved.  However it doesn't seem that this
  patch has been has been merged into the kernel, even though it was
  submitted well in time for the 3.19 merge window.  I was advised to
  file this bug report in the meantime.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.10
  Package: linux-image-3.16.0-29-generic 3.16.0-29.39
  ProcVersionSignature: Ubuntu 3.16.0-29.39-generic 3.16.7-ckt2
  Uname: Linux 3.16.0-29-generic x86_64
  ApportVersion: 2.14.7-0ubuntu8
  Architecture: amd64
   /dev/snd/controlC1:  dave       2338 F.... pulseaudio
   /dev/snd/controlC0:  dave       2338 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Wed Jan 21 05:14:38 2015
  InstallationDate: Installed on 2014-12-30 (22 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-29-generic.efi.signed root=UUID=b5b33d3f-e01a-4d2b-824f-8883fbfed316 ro quiet splash acpi_osi= vt.handoff=7
   linux-restricted-modules-3.16.0-29-generic N/A
   linux-backports-modules-3.16.0-29-generic  N/A
   linux-firmware                             1.138.1
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/26/2014
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: N550JK.208
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: N550JK
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN550JK.208:bd09/26/2014:svnASUSTeKCOMPUTERINC.:pnN550JK:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnN550JK:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.name: N550JK
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.

To manage notifications about this bug go to: