← Back to team overview

kernel-packages team mailing list archive

[Bug 1286552] Re: No wifi after suspend


I see it on a laptop that does not connect automatically to the wireless
network after wakeup. But I have the same issue also with a desktop with
wired ethernet.  So a more appropriate title would be 'network manager
fails to reconnect after resume', because the issue is not wifi

After a suspend/resume cycle, network manager does not reconnect.

For the desktop, given that this used to be a machine going to sleep
when unused and being waken from the lan, the issue is pretty bad. The
machine wakes... but with no network. Network manager stays there for
ever, with the connection ready and selected for automatic connection,
but does not even try to start the connection.

Since it completely breaks the usability of wol, please rise priority.

This is something recent.  I have also started to see it about November.
Furthermore, it used to work just fine with 14.04.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  No wifi after suspend

Status in linux package in Ubuntu:
Status in network-manager package in Ubuntu:

Bug description:
  After suspending ubuntu the wifi doesn't work. The solution given here
  connecting-after-suspend) worked for me but when I have updated my
  Ubuntu now it won't work. I have tried to test mainline kernel but it
  won't to boot with it.

  To reproduce the bug : just suspend the computer and then power it.
  There's no wifi network until you restart the computer.

  ProblemType: Bug
  DistroRelease: Ubuntu 13.10
  Package: ubuntu-release-upgrader-core 1:0.205.4
  ProcVersionSignature: Ubuntu 3.11.0-15.25-generic 3.11.10
  Uname: Linux 3.11.0-15-generic i686
  ApportVersion: 2.12.5-0ubuntu2.2
  Architecture: i386
  CrashDB: ubuntu
  Date: Sat Mar  1 15:20:39 2014
  InstallationDate: Installed on 2013-12-30 (61 days ago)
  InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Release i386 (20131017)
  MarkForUpload: True
  PackageArchitecture: all
  SourcePackage: ubuntu-release-upgrader
  Symptom: dist-upgrade
  UpgradeStatus: No upgrade log present (probably fresh install)
  ApportVersion: 2.12.5-0ubuntu2.2
  Architecture: i386
   /dev/snd/controlC0:  meradi     1503 F.... pulseaudio
  DistroRelease: Ubuntu 13.10
  HibernationDevice: RESUME=UUID=e71568e2-e875-4053-b3b7-2046540e78bf
  InstallationDate: Installed on 2013-12-30 (61 days ago)
  InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Release i386 (20131017)
  MachineType: Hewlett-Packard HP Compaq 6830s
  MarkForUpload: True
  Package: linux (not installed)
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.11.0-15-generic root=UUID=3eaae47b-7485-4723-8b3e-9f6dac7a01e4 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.11.0-15.25-generic 3.11.10
   linux-restricted-modules-3.11.0-15-generic N/A
   linux-backports-modules-3.11.0-15-generic  N/A
   linux-firmware                             1.116.2
  Tags:  saucy
  Uname: Linux 3.11.0-15-generic i686
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  WifiSyslog: Mar  1 15:34:33 meradi-HP-Compaq-6830s kernel: [ 4581.474196] perf samples too long (5002 > 5000), lowering kernel.perf_event_max_sample_rate to 25000
  dmi.bios.date: 03/12/2009
  dmi.bios.vendor: Hewlett-Packard
  dmi.bios.version: 68PZD Ver. F.0C
  dmi.board.name: 30E9
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: KBC Version 95.1C
  dmi.chassis.asset.tag: CNU91609Y2
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.modalias: dmi:bvnHewlett-Packard:bvr68PZDVer.F.0C:bd03/12/2009:svnHewlett-Packard:pnHPCompaq6830s:pvrF.0C:rvnHewlett-Packard:rn30E9:rvrKBCVersion95.1C:cvnHewlett-Packard:ct10:cvr:
  dmi.product.name: HP Compaq 6830s
  dmi.product.version: F.0C
  dmi.sys.vendor: Hewlett-Packard

To manage notifications about this bug go to: