← Back to team overview

kernel-packages team mailing list archive

[Bug 1393079] Re: Touchpad not working after suspend/resume


Executing xinput on my laptop (Acer Aspire V Nitro) gives:
  SYN1B7F:01 06CB:2970 UNKNOWN              id=14   [slave  pointer  (2)]
for my touchpad. 

I found a potential kernel patch which might solve the problem:

I only tried reloading the i2c-hid module and this worked for me. Only
the KDE settings for the touchpad are screwed up after that. Going into
KDE settings and click apply, everything is fine again.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Touchpad not working after suspend/resume

Status in linux package in Ubuntu:

Bug description:
  Ubuntu 14.10 on an Acer Laptop, model: Aspire E5-571G-941Y
  $ uname -a
  Linux Acer-Aspire-E5-571G 3.16.0-24-generic #32-Ubuntu SMP Tue Oct 28 13:07:32 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

  Every time I suspend, the trackpad no longer works when resuming.

  I see several other people have the same issue with the same laptop here:
  (some people say it's a 14.10 specific problem)

  I realize this report is very poor but please don't hesitate to request data / clarifications from me, I'll be happy to help.
  ApportVersion: 2.14.7-0ubuntu8
  Architecture: amd64
   /dev/snd/controlC0:  bod        3942 F.... pulseaudio
   /dev/snd/controlC1:  bod        3942 F.... pulseaudio
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 14.10
  HibernationDevice: RESUME=UUID=2e6e7d72-637c-4b16-8cda-0471dfb711d4
  InstallationDate: Installed on 2014-11-14 (15 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
  MachineType: Acer Aspire E5-571G
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-25-generic.efi.signed root=UUID=94aa9203-873c-4dff-8207-4e6b33a6a3e7 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
   linux-restricted-modules-3.16.0-25-generic N/A
   linux-backports-modules-3.16.0-25-generic  N/A
   linux-firmware                             1.138
  Tags:  utopic
  Uname: Linux 3.16.0-25-generic x86_64
  UpgradeStatus: Upgraded to utopic on 2014-11-14 (15 days ago)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 05/06/2014
  dmi.bios.vendor: Insyde Corp.
  dmi.bios.version: V1.04
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: EA50_HB
  dmi.board.vendor: Acer
  dmi.board.version: V1.04
  dmi.chassis.asset.tag: Chassis Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: Acer
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.04:bd05/06/2014:svnAcer:pnAspireE5-571G:pvrV1.04:rvnAcer:rnEA50_HB:rvrV1.04:cvnAcer:ct10:cvrChassisVersion:
  dmi.product.name: Aspire E5-571G
  dmi.product.version: V1.04
  dmi.sys.vendor: Acer

To manage notifications about this bug go to: