← Back to team overview

kernel-packages team mailing list archive

[Bug 1402331] Re: System will periodically lockup with [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... render ring idle


Christopher, I worked on the bisection tonight however when I ran the
command earlier this evening and built the kernel it built the latest
*-45 instead of *-35. I just tried the command I saw in:

Build Environment

If you've not built a kernel on your system before, there are some
packages needed before you can successfully build. You can get these
installed with:

    sudo apt-get build-dep linux-image-$(uname -r)

I ran the command again and got the below, where am I screwing up? I'm
really wanting to get this done as I have several other projects going
also and the 'freezes' are getting more and more frequent with the *-45

chris@localhost:~$ sudo apt-get build-dep linux-image-3.13.0-35-generic
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Picking 'linux' as source package instead of 'linux-image-3.13.0-35-generic'
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
15 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] n

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  System will periodically lockup with [drm:i915_hangcheck_elapsed]
  *ERROR* Hangcheck timer elapsed... render ring idle

Status in linux package in Ubuntu:

Bug description:
  I have noticed the lockups periodically since 09/13/2014. I can't
  remember what kernel version was in use then possibly kernel
  3.13.0-35-generic or -36. It has continued periodically through
  versions -39; -40 and now to -43.  The last time this has happened was
  today Dec 13 14:40:57 localhost kernel: [154858.820009]
  [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... render
  ring idle. At times when it locks up I will have a cursor on a black
  screen and will have to press the power button to restart other times
  it will lockup whenever I'm in an application such as Firefox or
  Evolution. At that time I can usually CTRL>ALT-F1 log in and run 'sudo
  reboot' to restart the system.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-43-generic 3.13.0-43.72
  ProcVersionSignature: Ubuntu 3.13.0-43.72-generic
  Uname: Linux 3.13.0-43-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.6
  Architecture: amd64
   /dev/snd/controlC0:  chris      2445 F.... pulseaudio
  CurrentDesktop: GNOME
  Date: Sat Dec 13 20:22:51 2014
  HibernationDevice: RESUME=UUID=bb329dc0-0642-4b6a-876a-12c2f02fb7f6
  InstallationDate: Installed on 2014-10-24 (50 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
   eth0      no wireless extensions.

   lo        no wireless extensions.
  MachineType: Dell Inc. OptiPlex 780
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-43-generic root=UUID=4254a7e9-429b-4f53-a08c-ae7ff839b98f ro quiet splash vt.handoff=7
   linux-restricted-modules-3.13.0-43-generic N/A
   linux-backports-modules-3.13.0-43-generic  N/A
   linux-firmware                             1.127.10

  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/13/2010
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A03
  dmi.board.name: 0C27VV
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A01
  dmi.chassis.asset.tag: LE0006476
  dmi.chassis.type: 6
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvrA03:bd02/13/2010:svnDellInc.:pnOptiPlex780:pvr:rvnDellInc.:rn0C27VV:rvrA01:cvnDellInc.:ct6:cvr:
  dmi.product.name: OptiPlex 780
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: