← Back to team overview

kernel-packages team mailing list archive

[Bug 1416001] Re: ISST-LTE: ubuntu15.04 installer is missing ibmvfc driver


Sent patch for Vivid to kernel-team mailing list for linux package.

** Changed in: linux (Ubuntu)
     Assignee: (unassigned) => Chris J Arges (arges)

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  ISST-LTE: ubuntu15.04 installer is missing ibmvfc driver

Status in debian-installer package in Ubuntu:
Status in linux package in Ubuntu:

Bug description:
  == Comment: #1 - Hemant Kumar <hemantkbajaj@xxxxxxxxxx> - 2015-01-20 11:27:19 ==
  Defect Description:

  I am trying to install ubuntu15.04LE on multipath disks, but while
  installtion installer is not able to find multipath disks.

  For enabling multipath support is have set "disk-
  detect/multipath/enable=true" parameter in grub menu while

  Here is the error which i am getting:

    lqqqqqqqqqqqqqqqqqqqqqqqqqqu [!] Detect disks tqqqqqqqqqqqqqqqqqqqqqqqqqqqk
    x                                                                         x
    x No disk drive was detected. If you know the name of the driver needed   x
    x by your disk drive, you can select it from the list.                    x
    x                                                                         x
    x Driver needed for your disk drive:                                      x
    x                                                                         x
    x                     continue with no disk drive                         x
    x                     login to iSCSI targets                              x
    x                     3w-9xxx                      a                      x
    x                     3w-sas                       a                      x
    x                     3w-xxxx                      a                      x
    x                     DAC960                       a                      x
    x                     a100u2w                      a                      x
    x                     aacraid                      a                      x
    x                     aic79xx                      a                      x
    x                     aic7xxx                                             x
    x                                                                         x
    x     <Go Back>                                                           x
    x                                                                         x

  <Tab> moves; <Space> selects; <Enter> activates buttons

  I have tried installing other distros and the installer is able to find the disks but ubuntu installer is giving error.

  lpar is at installation prompt, please have a look.


  == Comment: #10 - Carrie N. Mitsuyoshi <carriemi@xxxxxxxxxx> - 2015-01-27 11:22:52 ==
  (In reply to comment #6)
  > This seems to be a more fundamental error than multipath; the installer
  > cannot find any storage at all. I expect you will see the same error w/o the
  > above mutlipath parameter.  Can you try this and see if that is true?

  I tried the Ubuntu install without multipath enabled and still hit the
  issue. So it is not related to multipath. On the "Detect disks"
  screen, I scrolled through the list of available drivers and did not
  find ibmvfc.

  > So the installer is assuming, since it finds no storage, that you have some
  > adapter installed for which it has no driver.  I don't know if that's true
  > or not, but if you can identify the required driver for the adapter you are
  > targeting, that would be helpful.  Any other information about the adapter
  > hardware would be helpful too.

  The Ubuntu installer does not have the ibmvfc module.

  ~ # uname -a
  Linux highlp3 3.18.0-11-generic #12-Ubuntu SMP Fri Jan 23 22:45:52 UTC 2015 ppc64le GNU/Linux
  ~ # lsmod
  Module                  Size  Used by
  usb_storage            71250  0 
  ~ # modinfo ibmvfc
  modinfo: ERROR: Module ibmvfc not found.

  == Comment: #12 - Carrie N. Mitsuyoshi <carriemi@xxxxxxxxxx> - 2015-01-27 11:27:44 ==
  This is from a separate lpar, used to get the ibmvfc info for a running Ubuntu 15.04 system.

  (see attachment: modinfo ibmvfc)

  == Comment: #17 - David Heller <hellerda@xxxxxxxxxx> - 2015-01-28 14:13:46 ==
  So clearly ibmvfc is not a builtin on the ppc64el kernel.

  After poking around some more I can verify the ibmvfc.ko is missing
  from the installer initrd files -- both the netboot one and the one on
  the ISO.  I did find one installed system where the module is present
  so it's "around" but just not in the installer.

  So, I think the next step is to mirror this and request ibmvfc.ko be
  added to the installer.  The other alternative is to request that it
  get builtin all around.  Currently it's built as a module.

  Brian, is this correct?  Do we have a preference?

  == Comment: #18 - Brian J. King <bjking1@xxxxxxxxxx> - 2015-01-29 10:28:18 ==
  Yes, ibmvfc needs to be part of the install image. I don't think it matters too much whether its a module or built in. Consistency with ibmvscsi makes sense to me.

  == Comment: #19 - David Heller <hellerda@xxxxxxxxxx> - 2015-01-29 11:33:54 ==
  Thanks.  Changing the title accordingly.

To manage notifications about this bug go to: