← Back to team overview

kernel-packages team mailing list archive

[Bug 1113779] Re: 14e4:170c Broadcom bcm4401-b0 network card no longer functional


In a forum where I partecipate we solved the problem. 
We found that the problem is caused about a file called "blacklist-bcm43.conf" that put all the broadcom driver in blacklist after the installation (that no happened during live cd session).
This is the cause of the issue. 

You have to move this file from /etc/modprobe.d and reboot, later
network card works fine.

This is the content of /etc/modprobe.d/blacklist-bcm43.conf

paola@paola-Inspiron-1520:/etc/modprobe.d$ cat blacklist-bcm43.conf
# Warning: This file is autogenerated by bcmwl. All changes to this file will be lost.
blacklist b43
blacklist b43legacy
blacklist ssb
blacklist bcm43xx
blacklist brcm80211
blacklist brcmfmac
blacklist brcmsmac
blacklist bcma
blacklist b44
install wl modprobe -r b43 b44 b43legacy ssb; modprobe --ignore-install wl ; modprobe --ignore-install b44


Can see that all broadcom are blacklisted. 
I solved moving this file to Desktop and after a reboot the network card works fine.

>From terminal I used command "mv" to move the file to Desktop:

paola@paola-Inspiron-1520:~$ sudo mv /etc/modprobe.d/blacklist-bcm43.conf /home/paola/Scrivania


And after a reboot the network card works.

We talk about this problem on this thread: http://www.linux-magazine.it/forum/index.php/topic,15933.msg53955.html#msg53955 but it's only in italian, I'm sorry. 
I hope that solution works for other people that have this problem.

I dont know how this thread works, but if is possible someone report
this solution and what is the problem to whom it may concern.

Thank you.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  14e4:170c Broadcom bcm4401-b0 network card no longer functional

Status in “linux” package in Ubuntu:

Bug description:
  This actually happedned when I did an upgrade to 3.2.0-36-generic
  about a week ago.  The network card was working fine until I rebooted
  after the update.  Now to get internet access on this machine I have
  had to use a pcmcia network card.  It appears though I have been
  unable to confirm this, that the bcmlw update blacklisted all broadcom

  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: linux-image-3.2.0-37-generic 3.2.0-37.58
  ProcVersionSignature: Ubuntu 3.2.0-37.58-generic 3.2.35
  Uname: Linux 3.2.0-37-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
  ApportVersion: 2.0.1-0ubuntu17.1
  Architecture: amd64
   **** List of CAPTURE Hardware Devices ****
   card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
   /dev/snd/controlC0:  tom        9780 F.... pulseaudio
   /dev/snd/pcmC0D0p:   tom        9780 F...m pulseaudio
   Card hw:0 'Intel'/'HDA Intel at 0xefebc000 irq 42'
     Mixer name	: 'SigmaTel STAC9200'
     Components	: 'HDA:83847690,102801d4,00102201 HDA:14f12bfa,14f100c3,00090000'
     Controls      : 14
     Simple ctrls  : 7
  Date: Sat Feb  2 13:17:39 2013
  HibernationDevice: RESUME=UUID=bb8dbb09-d641-48d1-a1ca-e4f9296956e5
  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
  MachineType: Dell Inc. Latitude D520
  MarkForUpload: True
   Socket 0:
    PC Card
     Subdevice 0 (function 0) bound to driver "axnet_cs"
   PATH=(custom, no user)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-37-generic root=UUID=98c0e985-6278-48f4-832d-b54216f77312 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.2.0-37-generic N/A
   linux-backports-modules-3.2.0-37-generic  N/A
   linux-firmware                            1.79.1
  SourcePackage: linux
  UpgradeStatus: Upgraded to precise on 2013-01-30 (2 days ago)
  dmi.bios.date: 10/13/2006
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A02
  dmi.board.name: 0NF743
  dmi.board.vendor: Dell Inc.
  dmi.chassis.type: 8
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvrA02:bd10/13/2006:svnDellInc.:pnLatitudeD520:pvr:rvnDellInc.:rn0NF743:rvr:cvnDellInc.:ct8:cvr:
  dmi.product.name: Latitude D520
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: