← Back to team overview

kernel-packages team mailing list archive

[Bug 1300557] Re: Screen resolution no longer works


Okay, I got a seemingly successful install of the last Saucy kernel.
But it's not working very well: I get a super-low-res login screen, and
the system doesn't respond to keyboard or mouse.  (It does notice the
power button, so it's not frozen).  This happens both with the default
boot on that kernel version, and with the Upstart boot.

So I can't say for certain whether things would still work correctly
with a Saucy kernel.  It wasn't this broken at the time!

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Screen resolution no longer works

Status in linux package in Ubuntu:

Bug description:
  My display's native resolution is 2560×1440 pixels.  Prior to, I
  think, Saucy I could only reach this resolution by adding it using
  xrandr, and then calling xrandr on boot/login to select that
  resolution.  The Display preferences did not show any higher options
  than 1920×1200.

  In Saucy, the native resolution just worked, and I could stop using
  xrandr.  It also worked in Trusty in the alpha releases, up to (and I
  think including) beta-1.  But today (this is not an April's fool, is
  it?) I rebooted after an upgrade, and found myself back in 1920×1200.
  Again, the Display preferences list that resolution as the highest
  possible.  But this time, attempts to ‘xrandr --addmode’ my native
  resolution failed.

  The error message wasn't very helpful; I'll try to reproduce it later
  but it throws my display into yet a lower resolution that's hard to
  work with.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: xorg 1:7.7+1ubuntu8
  ProcVersionSignature: Ubuntu 3.13.0-20.42-generic 3.13.7
  Uname: Linux 3.13.0-20-generic x86_64

  ApportVersion: 2.14-0ubuntu1
  Architecture: amd64
  CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Tue Apr  1 09:59:00 2014
  DistUpgraded: 2014-01-22 17:01:10,909 DEBUG enabling apt cron job
  DistroCodename: trusty
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes
   Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])
     Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000]
  InstallationDate: Installed on 2013-08-03 (240 days ago)
  InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
  MachineType: Gigabyte Technology Co., Ltd. Z87-D3HP
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-20-generic root=UUID=12085c8d-328f-4c75-a04c-184c592f61ee ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: Upgraded to trusty on 2014-01-22 (68 days ago)
  dmi.bios.date: 05/16/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: F4
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: Z87-D3HP-CF
  dmi.board.vendor: Gigabyte Technology Co., Ltd.
  dmi.board.version: x.x
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrF4:bd05/16/2013:svnGigabyteTechnologyCo.,Ltd.:pnZ87-D3HP:pvrTobefilledbyO.E.M.:rvnGigabyteTechnologyCo.,Ltd.:rnZ87-D3HP-CF:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: Z87-D3HP
  dmi.product.version: To be filled by O.E.M.
  dmi.sys.vendor: Gigabyte Technology Co., Ltd.
  version.compiz: compiz 1:0.9.11+14.04.20140328-0ubuntu1
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.52-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.0-1ubuntu1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.0-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.15.0-1ubuntu7
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
  xserver.bootTime: Tue Apr  1 09:52:36 2014
  xserver.configfile: default

  xserver.logfile: /var/log/Xorg.0.log
   product id                               16510
   vendor                                     DEL
  xserver.version: 2:1.15.0-1ubuntu7

To manage notifications about this bug go to: