← Back to team overview

kernel-packages team mailing list archive

[Bug 1402393] Re: Touchpad elantech on Fujitsu E554 doesn't work at all


Confirmed working on latest (two days ago) image.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Touchpad elantech on Fujitsu E554 doesn't work at all

Status in linux package in Ubuntu:

Bug description:
  The touchpad on my brand new Fujitsu E554 doesn't work. Nothing work.

  xinput list report (partial output only).

  Virtual core pointer                    	id=2	[master pointer  (3)]
  ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
  ⎜   ↳ USB Optical Mouse                       	id=12	[slave  pointer  (2)]
  ⎜   ↳ ETPS/2 Elantech Touchpad                	id=14	[slave  pointer  (2)]

  The "pointer" is the trackpoint (which doesn't work either)
  Usb optical mouse is the mouse i added as a replacement
  ETPS/2 Elantech Touchpad is the non working touchpad.

  In dmesg i get

  [  347.473934] psmouse serio2: Touchpad at isa0060/serio2/input0 lost sync at byte 6
  [  347.473942] psmouse serio2: issuing reconnect request

  This is ubuntu 3.16.0-28 generic (utopic) on AMD 64.

  I have tried with 3.17, same result.

  I have tried to install 3.18rc2 but my laptop won't boot. I will try
  from source.

  The touchpad is working correctly under Windows 7. I have flashed the

  ProblemType: Bug
  DistroRelease: Ubuntu 14.10
  Package: linux-image-3.16.0-28-generic 3.16.0-28.37
  ProcVersionSignature: Ubuntu 3.16.0-28.37-generic 3.16.7-ckt1
  Uname: Linux 3.16.0-28-generic x86_64
  ApportVersion: 2.14.7-0ubuntu8
  Architecture: amd64
   /dev/snd/controlC1:  vincent    2244 F.... pulseaudio
   /dev/snd/controlC0:  vincent    2244 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Sun Dec 14 15:00:22 2014
  HibernationDevice: RESUME=UUID=fdb3c54c-48f0-4668-a826-b4ae39dd359a
  InstallationDate: Installed on 2014-12-14 (0 days ago)
  InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
  MachineType: FUJITSU LIFEBOOK E554
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-28-generic root=UUID=f9bbd277-cae6-45f3-971f-fb96ea58fd71 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.16.0-28-generic N/A
   linux-backports-modules-3.16.0-28-generic  N/A
   linux-firmware                             1.138
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/17/2014
  dmi.bios.vendor: FUJITSU // Phoenix Technologies Ltd.
  dmi.bios.version: Version 1.05
  dmi.board.name: FJNB281
  dmi.board.vendor: FUJITSU
  dmi.board.version: E2
  dmi.chassis.type: 10
  dmi.chassis.vendor: FUJITSU
  dmi.chassis.version: LIFEBOOK E554
  dmi.modalias: dmi:bvnFUJITSU//PhoenixTechnologiesLtd.:bvrVersion1.05:bd11/17/2014:svnFUJITSU:pnLIFEBOOKE554:pvr10601583232:rvnFUJITSU:rnFJNB281:rvrE2:cvnFUJITSU:ct10:cvrLIFEBOOKE554:
  dmi.product.name: LIFEBOOK E554
  dmi.product.version: 10601583232
  dmi.sys.vendor: FUJITSU

To manage notifications about this bug go to: