← Back to team overview

kernel-packages team mailing list archive

[Bug 1440174] Re: Keyboard and Mouse don't work with latest Kernel


I have Ubuntu installed on my 17'' core-duo intel imac, with an encrypted root partition.
Version 12.04 with 13.5.0-17-generic worked ok, but I  updated to the LTS version 14.04.
The system now freezes before asking for my encryption password when booting (I am using EFI with grub2)
with my old kernel (13.5.0-17-generic) and with no args on the kernel command line. If I put nomodeset the boot
progresses to the encryption password and I can successfully login, however the video is completely scrambled (I literally cannot
make out anything). Having tried many ways to fix the video, I tried the latest kernel (3.13.0-48-generic). In this case
the boot gets to the password, but the keyboard/mouse does not respond. Again I tried many fixes, unsuccesfully. I installed the extras
so as to have usbhid, mac_hid etc, and found that the behaviour now reverted precisely to that outlined above for 13.5.0-17-generic;
that is scrambled graphics but successful login (with nomodeset), and ok graphics but no keyboard (without nomodeset).
I tried manually adding only the hid modules to my initrd.img-3.13.0-48-generic built prior to install of extra, but found graphics again
ok but still no keyboard !

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Keyboard and Mouse don't work with latest Kernel

Status in linux package in Ubuntu:

Bug description:
  Description:	Ubuntu 14.04.2 LTS
  Release:	14.04

  2) Linux / The kernel

  3) I expected my usb devices to work on the login page

  4) They don't work :)


  Upon the upgrade to kernel 3.13.0-48-generic my USB devices don't
  work, so when I did a normal launch of my computer, I could not sign
  into it since my usb devices were not working.

  I was able to sign and and use my computer as normal when I revert to
  kernel 3.13.0-46-generic.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-46-generic 3.13.0-46.79
  ProcVersionSignature: Ubuntu 3.13.0-46.79-generic 3.13.11-ckt15
  Uname: Linux 3.13.0-46-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.8
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Fri Apr  3 13:06:36 2015
  HibernationDevice: RESUME=UUID=ae54d2d5-4931-4fcc-8996-aa3adf03cbb6
  InstallationDate: Installed on 2015-01-01 (92 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
  MachineType: Dell Inc. Inspiron 3847
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-46-generic root=UUID=32967a77-1e86-4f47-abfd-a3b98a6e9af6 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.13.0-46-generic N/A
   linux-backports-modules-3.13.0-46-generic  N/A
   linux-firmware                             1.127.11
   0: phy0: Wireless LAN
   	Soft blocked: no
   	Hard blocked: no
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 04/03/2014
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A04
  dmi.board.name: 088DT1
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A01
  dmi.chassis.type: 3
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvrA04:bd04/03/2014:svnDellInc.:pnInspiron3847:pvr:rvnDellInc.:rn088DT1:rvrA01:cvnDellInc.:ct3:cvr:
  dmi.product.name: Inspiron 3847
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: