← Back to team overview

kernel-packages team mailing list archive

[Bug 1454207] Re: Samsung 730U3E LCD backlight brightness control doesn't work


Stefan Burnicki, the next step is to fully commit bisect from kernel
3.13 to 3.16 in order to identify the last good kernel commit, followed
immediately by the first bad one. This will allow for a more expedited
analysis of the root cause of your issue. Could you please do this
following https://wiki.ubuntu.com/Kernel/KernelBisection ?

Please note, finding adjacent kernel versions is not fully commit

Thank you for your understanding.

Helpful bug reporting tips:

** Tags added: needs-bisect regression-release utopic

** Changed in: linux (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Samsung 730U3E LCD backlight brightness control doesn't work

Status in linux package in Ubuntu:

Bug description:
  Fn-shortcuts work and the value in /sys/class/backlight/intel_backlight/brightness changes, but is has no physical effect.
  Only setting /sys/class/backlight/intel_backlight/brightness to 0 turns the LCD off, changing it to any other value turns it on again.

  I tried to set different boot parameters in /etc/defaults/grub
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=1"
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=0"
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"
  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_bios_initial_backlight=0"

  For each change, I called update-grub, restarted, and verfied the
  settings with /proc/cmdline. Nothing worked for me.

  I also tested this with the newest mainline kernel (4.1-rc2), but the
  bug still exists.

  It work with trusty and stopped working with utopic. I thought this
  issue would may be fixed in vivid, but it isn't.

  Please tell me what other information you need in order to fix this.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: linux-image-3.19.0-16-generic 3.19.0-16.16
  ProcVersionSignature: Ubuntu 3.19.0-16.16-generic 3.19.3
  Uname: Linux 3.19.0-16-generic x86_64
  ApportVersion: 2.17.2-0ubuntu1
  Architecture: amd64
   /dev/snd/controlC0:  stefan     1383 F.... pulseaudio
  CurrentDesktop: KDE
  Date: Tue May 12 13:08:51 2015
  HibernationDevice: RESUME=UUID=34e06653-f31c-45ef-80ca-9eddcae5134f
  InstallationDate: Installed on 2015-03-10 (62 days ago)
  InstallationMedia: Kubuntu-Plasma-5 14.10 "Utopic Unicorn" - Release amd64 (20141022)
  MachineType: SAMSUNG ELECTRONICS CO., LTD. 730U3E/740U3E
   0 inteldrmfb
   1 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.19.0-16-generic root=/dev/mapper/kubuntu--plasma--5--vg-root ro quiet splash video.use_bios_initial_backlight=0
   linux-restricted-modules-3.19.0-16-generic N/A
   linux-backports-modules-3.19.0-16-generic  N/A
   linux-firmware                             1.143
  SourcePackage: linux
  UpgradeStatus: Upgraded to vivid on 2015-04-26 (16 days ago)
  dmi.bios.date: 05/30/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P05ABW.060.130530.dg
  dmi.board.asset.tag: No Asset Tag
  dmi.board.name: NP730U3E-S03DE
  dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.board.version: SEC_SW_REVISION_1234567890ABCD
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 9
  dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
  dmi.chassis.version: N/A
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP05ABW.060.130530.dg:bd05/30/2013:svnSAMSUNGELECTRONICSCO.,LTD.:pn730U3E/740U3E:pvrP05ABW:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP730U3E-S03DE:rvrSEC_SW_REVISION_1234567890ABCD:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvrN/A:
  dmi.product.name: 730U3E/740U3E
  dmi.product.version: P05ABW
  dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.

To manage notifications about this bug go to: