← Back to team overview

kernel-packages team mailing list archive

[Bug 1338706] Re: Samsung SSD 840 failed to get NCQ Send/Recv Log Emask 0x1 failed to set xfermode (err_mask=0x40) on upstream kernels >= 3.12


I am running the EXT0DB6Q firmware on my 840 EVO + 3.13.0-53 , and think
this issue may have cleared up somewhat.

The first time I ran   
chiluk@beastly:/etc/cron.weekly$ sudo fstrim /home
I got.
^[OQfstrim: /home: FITRIM ioctl failed: Input/output error

The Log showed
[164782.716062] ata2.00: exception Emask 0x0 SAct 0x1000004 SErr 0x0 action 0x6 frozen
[164782.716079] ata2.00: failed command: WRITE FPDMA QUEUED
[164782.716081] ata2.00: cmd 61/60:10:28:b6:c0/00:00:1e:00:00/40 tag 2 ncq 49152 out
[164782.716081]          res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[164782.716083] ata2.00: status: { DRDY }
[164782.716084] ata2.00: failed command: WRITE FPDMA QUEUED
[164782.716086] ata2.00: cmd 61/08:c0:00:1b:ce/00:00:30:00:00/40 tag 24 ncq 4096 out
[164782.716086]          res 40/00:01:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
[164782.716087] ata2.00: status: { DRDY }
[164782.716090] ata2: hard resetting link
[164783.036088] ata2: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[164783.036268] ata2.00: supports DRM functions and may not be fully accessible
[164783.036537] ata2.00: supports DRM functions and may not be fully accessible
[164783.036584] ata2.00: configured for UDMA/133
[164783.052085] ata2.00: device reported invalid CHS sector 0
[164783.052093] ata2: EH complete

It sounds like the drive was just taking too long for the writes to
complete. Hence the (timeout).   I ran it a second time, and did not get
these errors.  These errors may also be related to the charge
degredation of the the TLC nand on these drives.  This may be also
partially due to the way the samsung firmware is managing sectors on the
drive.  In that it might be needing to restructure/rewrite metadata due
to my recent firmware update.

I then went and cleaned some 30gb out of my home dir, and ran it a third
time.  I did not get any errors this time.

Also how are you guys "enabling trim".  It is recommended that you not
enable trim by adding discard to the mount options.  This will greatly
slow down deletes.  Instead it is recommended that you let fstrim-all
run out of anacron /etc/cron.weekly/fstrim.  Your above trim tests will
show that trim is not enabled, when it is actually being run weekly in
the background.  If you need trim run more frequently than that move it
to the daily or hourly folder.  Just be careful with doing so.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Samsung SSD 840 failed to get NCQ Send/Recv Log Emask 0x1 failed to
  set xfermode (err_mask=0x40) on upstream kernels >= 3.12

Status in linux package in Ubuntu:

Bug description:
  Samsung SSD 840 Series failed to get NCQ Send/Recv Log Emask 0x1.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-30-generic 3.13.0-30.55
  ProcVersionSignature: Ubuntu 3.13.0-30.55-generic
  Uname: Linux 3.13.0-30-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.2
  Architecture: amd64
   /dev/snd/controlC0:  user       2131 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Mon Jul  7 20:01:28 2014
  HibernationDevice: RESUME=UUID=685afcb7-7aa6-4048-af15-091d3bcd3b35
  InstallationDate: Installed on 2014-06-22 (14 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
   eth0      no wireless extensions.

   lo        no wireless extensions.
  MachineType: System manufacturer System Product Name
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.13.0-30-generic root=UUID=d7c2e1cb-d046-460c-83b8-0cfbb330d095 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.13.0-30-generic N/A
   linux-backports-modules-3.13.0-30-generic  N/A
   linux-firmware                             1.127.4

  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 09/10/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 0901
  dmi.board.asset.tag: To Be Filled By O.E.M.
  dmi.board.name: M3N78-EM
  dmi.board.vendor: ASUSTeK Computer INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0901:bd09/10/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM3N78-EM:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: System Product Name
  dmi.product.version: System Version
  dmi.sys.vendor: System manufacturer

To manage notifications about this bug go to: