← Back to team overview

kernel-packages team mailing list archive

[Bug 1456837] Re: USB drive errors with kernel version 3.13.0-35 and above


Gary Dalmadge, could you please test the latest mainline kernel 4.1-rc4
and advise to the results?

** Tags added: vivid

** Changed in: linux (Ubuntu)
   Importance: Low => Medium

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  USB drive errors with kernel version 3.13.0-35 and above

Status in linux package in Ubuntu:

Bug description:
  I am seeing various USB drive errors while trying to use the drives.

  For instance, I am unable to successfully create a new file system on
  the drives. One example is parted which returns the following error:
  Error fsyncing/closing /dev/sdc: Remote I/O error

  dmesg shows the following error in this case: end_request: critical
  target error, dev sdc, sector 0

  The errors appear with different brands and types of USB drives. I
  have tested the drives on other systems and they are okay.

  Earlier versions of Ubuntu (prior to 14.04) do not show these errors.
  I am running the i386 version.

  I have tried different versions of the kernel. It seems to have
  appeared in the 3.13.0-35 kernel. I do not see it while using the
  3.13.0-34 kernel, but see it in newer kernels. It is present in both
  the generic and low latency versions of the kernel.

  I have tried the Utopic kernels with the same results.

  I have also tried the upstream kernels 4.0.3-040003, and
  4.1.0-040100rc3 and still see the problem.

  I have multiple systems, and am only seeing this on systems with AMD
  processors and certain nVidia chipsets, for instance GeForce 6100
  Northbridge/nForce 410 Southbridge.

  Here is the output of lsb_release -rd :
  Description:	Ubuntu 14.04.2 LTS
  Release:	14.04

  Please let me know if you need additional information. I will be happy
  to provide any information that you would find helpful.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-52-lowlatency 3.13.0-52.86
  ProcVersionSignature: Ubuntu 3.13.0-52.86-lowlatency 3.13.11-ckt18
  Uname: Linux 3.13.0-52-lowlatency i686
  ApportVersion: 2.14.1-0ubuntu3.10
  Architecture: i386
   /dev/snd/controlC0:  gary       1804 F.... qasmixer
                        gary       1952 F.... pulseaudio
  CurrentDesktop: XFCE
  Date: Tue May 19 18:06:54 2015
  HibernationDevice: RESUME=UUID=c5872602-e17b-4383-8845-4b83d5332f13
  InstallationDate: Installed on 2013-08-12 (645 days ago)
  InstallationMedia: Ubuntu-Studio 12.04.2 "Precise Pangolin" - Release i386 (20130213)
   lo        no wireless extensions.
   eth0      no wireless extensions.
   Bus 001 Device 003: ID 04cc:1521 ST-Ericsson USB 2.0 Hub
   Bus 001 Device 002: ID 04cf:8818 Myson Century, Inc. USB2.0 to ATAPI Bridge Controller
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  ProcFB: 0 nouveaufb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-52-lowlatency root=UUID=e0b2c957-2687-46ae-ad75-68dd964b02b2 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.13.0-52-lowlatency N/A
   linux-backports-modules-3.13.0-52-lowlatency  N/A
   linux-firmware                                1.127.11
  SourcePackage: linux
  UpgradeStatus: Upgraded to trusty on 2014-04-30 (384 days ago)
  dmi.bios.date: 08/11/2006
  dmi.bios.vendor: Phoenix Technologies, LTD
  dmi.bios.version: 6.00 PG
  dmi.board.name: C51MCP51
  dmi.chassis.type: 3
  dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd08/11/2006:svn:pn:pvr:rvn:rnC51MCP51:rvr:cvn:ct3:cvr:

To manage notifications about this bug go to: