← Back to team overview

kernel-packages team mailing list archive

[Bug 1457863] Re: interface eth0 disappears after network cable unplug/re-plug


Eric Carlier, this bug report is being closed due to your last comment
regarding this is no longer reproducible. For future reference you can
manage the status of your own bugs by clicking on the current status in
the yellow line and then choosing a new status in the revealed drop down
box. You can learn more about bug statuses at
https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time
to report this bug and helping to make Ubuntu better. Please submit any
future bugs you may find.

** Changed in: linux (Ubuntu)
       Status: Triaged => Invalid

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  interface eth0 disappears after network cable unplug/re-plug

Status in linux package in Ubuntu:

Bug description:
  The following bug is reproducible with linux-image-3.13.0-53-generic,
  but not with linux-image-3.13.0-52-generic.

  When I unplug the Ethernet cable from my laptop, I get the following messages in /var/log/kern.log after a few seconds (~20s):
  May 22 13:59:36 host kernel: [ 5498.465626] pciehp 0000:00:1c.5:pcie04: Card not present on Slot(5)
  May 22 13:59:36 host kernel: [ 5498.478755] pciehp 0000:00:1c.5:pcie04: Card present on Slot(5)
  May 22 13:59:36 host kernel: [ 5498.598744] pciehp 0000:00:1c.5:pcie04: Device 0000:06:00.0 already exists at 0000:06:00, cannot hot-add
  May 22 13:59:36 host kernel: [ 5498.598755] pciehp 0000:00:1c.5:pcie04: Cannot add device at 0000:06:00
  May 22 13:59:36 host kernel: [ 5498.718646] atl1c 0000:06:00.0: MAC state machine can't be idle since disabled for 10ms second

  Then, when I re-plug the cable, eth0 does not appear in network manager; there is no message in kern.log.
  eth0 does not appear in ifconfig -a

  $ ifconfig -a
  lo        Link encap:Local Loopback  
            inet addr:  Mask:
            inet6 addr: ::1/128 Scope:Host
            UP LOOPBACK RUNNING  MTU:65536  Metric:1
            RX packets:11586 errors:0 dropped:0 overruns:0 frame:0                                                                                                        
            TX packets:11586 errors:0 dropped:0 overruns:0 carrier:0                                                                                                      
            collisions:0 txqueuelen:0                                                                                                                                     
            RX bytes:16392353 (16.3 MB)  TX bytes:16392353 (16.3 MB)                                                                                                      

  wlan0     Link encap:Ethernet  HWaddr 48:5d:xx:xx:xx:xx  
            inet addr:192.168.xx.xx  Bcast:192.168.xx.xx  Mask:
            inet6 addr: fe80::xxxx:xxxx:xxxx:xxxx/64 Scope:Link
            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
            RX packets:19 errors:0 dropped:0 overruns:0 frame:0
            TX packets:66 errors:0 dropped:0 overruns:0 carrier:0
            collisions:0 txqueuelen:1000 
            RX bytes:2651 (2.6 KB)  TX bytes:12364 (12.3 KB)

  I tried to reinitialize networking with the following:
  sudo modprobe -r atl1c
  sudo modprobe atl1c

  Still no eth0 and no message in kern.log

  I tried
  $ sudo ifup eth0
  Ignoring unknown interface eth0=eth0.

  Same symptoms occur when I reboot my router, and its Ethernet
  interface becomes temporarily unavailable.

  Only way I found to restore eth0 was rebooting.
  ApportVersion: 2.14.1-0ubuntu3.11
  Architecture: amd64
   /dev/snd/controlC1:  chewy      3002 F.... pulseaudio
   /dev/snd/controlC0:  chewy      3002 F.... pulseaudio
  CurrentDesktop: KDE
  DistroRelease: Ubuntu 14.04
  EcryptfsInUse: Yes
  HibernationDevice: RESUME=UUID=17ba1751-f706-417b-ac40-1b4a7be825d8
  InstallationDate: Installed on 2012-12-29 (873 days ago)
  InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120423)
  MachineType: ASUSTeK Computer Inc. N53Jq
  NonfreeKernelModules: nvidia
  Package: linux (not installed)
  ProcFB: 0 VESA VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-53-generic root=UUID=d48490d1-ca6a-448d-82e6-6397021cd403 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.13.0-53.89-generic 3.13.11-ckt19
   linux-restricted-modules-3.13.0-53-generic N/A
   linux-backports-modules-3.13.0-53-generic  N/A
   linux-firmware                             1.127.12
  Tags:  trusty
  Uname: Linux 3.13.0-53-generic x86_64
  UpgradeStatus: Upgraded to trusty on 2014-09-05 (259 days ago)
  UserGroups: adm admin cdrom dialout disk fuse lpadmin mediatomb plugdev sambashare vboxusers wireshark
  _MarkForUpload: True
  dmi.bios.date: 01/25/2011
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: N53Jq.211
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: N53Jq
  dmi.board.vendor: ASUSTeK Computer Inc.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK Computer Inc.
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrN53Jq.211:bd01/25/2011:svnASUSTeKComputerInc.:pnN53Jq:pvr1.0:rvnASUSTeKComputerInc.:rnN53Jq:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
  dmi.product.name: N53Jq
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK Computer Inc.

To manage notifications about this bug go to: