← Back to team overview

kernel-packages team mailing list archive

[Bug 1242321] Re: USB 3.0 Harddrive not recognised


James Cloos wrote in comment 34:

> Switching to the performance govenor, removing the drive and re-adding it worked around the bug.
> Something must be blocking power to the xhci when the cpu is saving power...?

I believe that USB autosuspend is the culprit here. I'm seeing this
problem on Fedora Linux as well, so I suspect it's an upstream bug.

For those of you who are having this problem: please try disabling USB
autosuspend on all USB devices, by running the following command as

$ for F in /sys/bus/usb/devices/*/power/control; do echo on >"${F}";

You can then verify that the power control status for all devices is
"on", not "auto". E.g.:

$ grep . /sys/bus/usb/devices/*/power/control

If you do this, do your USB3 ports work properly?

(For me, on Fedora Linux, disabling USB autosuspend made all my USB
ports work perfectly.)

Note: if you've already caused the xhci_hcd driver to die, you'll need
to reboot first.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  USB 3.0 Harddrive not recognised

Status in linux package in Ubuntu:

Bug description:
  Ubuntu is not recognising any device plugged into any USB 3.0 ports.
  Sometimes Ubuntu will freeze for a few seconds when you plug something
  into a USB 3.0 port; when Ubuntu comes out of the freeze, the device
  is still NOT recognised.

  No problems with USB 2.0 ports and devices.

  The USB 3.0 on this computer only works in Windows 7 (I'm dual booting
  Ubuntu 13.10 and Windows 7, both are 64-bit).

To manage notifications about this bug go to: