← Back to team overview

kernel-packages team mailing list archive

[Bug 1472384] Re: grub-install doesn't include raid5rec.mod


With the latest Wily image I still get the same error.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  grub-install doesn't include raid5rec.mod

Status in linux package in Ubuntu:

Bug description:
  I just did a fresh install of Ubuntu 14.04.2 using the official
  install medium onto my NAS. My NAS contains three drives which I run
  in a RAID5 configuration with LVM on top. I setup each drive to have a
  128MB EFI partition which stores grubx64.efi and put the rest of the
  drive under the RAID5+LVM configuration. The Ubuntu 14.04.2 and 15.04
  installs were happy to let me do that however when I try to boot into
  the freshly installed system the GRUB command prompt came up.

  While I was able to see the LVM partitions using ls I couldn't access
  them because I needed raid5rec.mod. I booted into a live CD and used
  grub-mkimage to create a grubx64.efi image which had raid5rec.mod, and
  all the other modules I needed to boot, embedded into grubx64.efi.

  Possible resolutions
  1. Store all grub modules on the EFI partition
  2. Modify grub-install to create grubx64.efi with all block/file system modules embedded into the image needed to access the partition which contains the grub modules
  AlsaVersion: Advanced Linux Sound Architecture Driver Version k3.16.0-43-generic.
  AplayDevices: Error: [Errno 2] No such file or directory
  ApportVersion: 2.14.1-0ubuntu3.11
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/hwC1D0', '/dev/snd/pcmC1D2c', '/dev/snd/pcmC1D1p', '/dev/snd/pcmC1D0c', '/dev/snd/pcmC1D0p', '/dev/snd/controlC1', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D3p', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
  CRDA: Error: [Errno 2] No such file or directory
  Card0.Amixer.info: Error: [Errno 2] No such file or directory
  Card0.Amixer.values: Error: [Errno 2] No such file or directory
  Card1.Amixer.info: Error: [Errno 2] No such file or directory
  Card1.Amixer.values: Error: [Errno 2] No such file or directory
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=/dev/mapper/NAS-SWAP
  InstallationDate: Installed on 2015-07-07 (0 days ago)
  InstallationMedia: Ubuntu-Server 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
   eth0      no wireless extensions.
   lo        no wireless extensions.
   lxcbr0    no wireless extensions.
  MachineType: ASUS All Series
  Package: linux (not installed)
   PATH=(custom, no user)
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-43-generic.efi.signed root=/dev/mapper/NAS-ROOT ro nomdmonddf nomdmonisw
  ProcVersionSignature: Ubuntu 3.16.0-43.58~14.04.1-generic 3.16.7-ckt13
   linux-restricted-modules-3.16.0-43-generic N/A
   linux-backports-modules-3.16.0-43-generic  N/A
   linux-firmware                             1.127.12
  RfKill: Error: [Errno 2] No such file or directory
  Tags:  trusty
  Uname: Linux 3.16.0-43-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  _MarkForUpload: True
  dmi.bios.date: 05/14/2015
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: 1201
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: AM1M-A
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: Rev X.0x
  dmi.chassis.asset.tag: Asset-1234567890
  dmi.chassis.type: 3
  dmi.chassis.vendor: Chassis Manufacture
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1201:bd05/14/2015:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnAM1M-A:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
  dmi.product.name: All Series
  dmi.product.version: System Version
  dmi.sys.vendor: ASUS

To manage notifications about this bug go to: