← Back to team overview

kernel-packages team mailing list archive

[Bug 1002570] Re: [Sony VAIO VGN-G21VN_B] Ricoh R5C843 SD Card reader not working


*** This bug is a duplicate of bug 1362168 ***

I tried with the latest mainline kernel (4.2 RC8) on ubuntu 15.04 but
the problem is still here.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  [Sony VAIO VGN-G21VN_B] Ricoh R5C843 SD Card reader not working

Status in Linux:
Status in linux package in Ubuntu:

Bug description:
  SD Card reader is not working. When I insert a SD or SDHC card nothing
  happens. The reader is not even listed under lspci. I have updated all
  the packages with apt. I tried to boot Ubuntu (12.04) with an SD
  plugged in but no luck. This notebook has a (separate slot) Ricoh
  R5C592 Memory Stick Reader that is working as expected (auto mounts
  the MS when inserted in the reader). Expected behavior: SD card reader
  to correctly read the inserted SD card.


  ProblemType: Bug
  DistroRelease: Ubuntu 12.04
  Package: linux-image-3.2.0-24-generic 3.2.0-24.38
  ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
  Uname: Linux 3.2.0-24-generic x86_64
  AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
   **** List of PLAYBACK Hardware Devices ****
   card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
  ApportVersion: 2.0.1-0ubuntu7
  Architecture: amd64
   **** List of CAPTURE Hardware Devices ****
   card 0: Intel [HDA Intel], device 0: ALC262 Analog [ALC262 Analog]
     Subdevices: 1/1
     Subdevice #0: subdevice #0
   /dev/snd/controlC0:  marco      1682 F.... pulseaudio
   Card hw:0 'Intel'/'HDA Intel at 0xf4540000 irq 44'
     Mixer name	: 'Realtek ALC262'
     Components	: 'HDA:10ec0262,104d1800,00100100 HDA:14f12c06,104d1700,00100000'
     Controls      : 17
     Simple ctrls  : 9
  Date: Tue May 22 00:58:07 2012
  HibernationDevice: RESUME=UUID=c8ceba03-f7ab-48f3-a017-ae1628cc20e9
  InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
  MachineType: Sony Corporation VGN-G21VN_B
   Socket 0:
     no product info available
   Socket 0:
     no card
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=6bd04d78-2cc1-4602-aa72-cb15d7dde368 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.2.0-24-generic N/A
   linux-backports-modules-3.2.0-24-generic  N/A
   linux-firmware                            1.79
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/21/2007
  dmi.bios.vendor: Phoenix Technologies LTD
  dmi.bios.version: R0021N9
  dmi.board.asset.tag: N/A
  dmi.board.name: VAIO
  dmi.board.vendor: Sony Corporation
  dmi.board.version: N/A
  dmi.chassis.type: 10
  dmi.chassis.vendor: Sony Corporation
  dmi.chassis.version: N/A
  dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrR0021N9:bd08/21/2007:svnSonyCorporation:pnVGN-G21VN_B:pvrJ002SHP8:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
  dmi.product.name: VGN-G21VN_B
  dmi.product.version: J002SHP8
  dmi.sys.vendor: Sony Corporation

To manage notifications about this bug go to: