← Back to team overview

kernel-packages team mailing list archive

[Bug 1490543] Re: gsettings fails to set wallpaper


>From Comment #3 I installed


which is the latest I saw, dated 8-30-2015.

gsettings still fails, wallpaper turns into some brown default.

Settings Appearance still works.

This is the code that fails that worked fine a couple weeks ago:

gsettings set org.gnome.desktop.background picture-uri 'file:////home/jerry/Pictures/Shark_Island.jpg'
exit 0

I also tried this gsettings on an Acer Laptop with Wily updated
recently, gsettings fails the same way.

Note that the linux-headers-4.2.0-040200_4.2.0-040200.201508301530_
is a bit of a bear because the desktop icons fall off the left of the screen so it's pretty hard to guess where the icons are. 

** Changed in: linux (Ubuntu)
       Status: Incomplete => Confirmed

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  gsettings fails to set wallpaper

Status in linux package in Ubuntu:

Bug description:
  until recent updates,

  gsettings set org.gnome.desktop.background picture-uri

  reset wallpaper to the desired picture.  Most of the time Wily boots
  to a horizontally hashed wallpaper which used to be corrected by doing
  gsettings once or twice or three times, now I have to go to settings >
  wallpaper > to set the jpg several times until it clears up.

  Now gsettings fails, gets the original brown screen.  gsettings is
  broken failing to set the desired wallpaper.

  DISTRIB_DESCRIPTION="Ubuntu Wily Werewolf (development branch)"
  Linux Lenovo2 4.1.0-3-generic #3-Ubuntu SMP Tue Jul 28 12:25:10 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
  model name	: Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz
  model name	: Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz
  00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

  14.04-3 LTS runs perfectly, so does 14.10 and 15.04 up through

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.1.0-3-generic 4.1.0-3.3 [modified: boot/vmlinuz-4.1.0-3-generic]
  ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3
  Uname: Linux 4.1.0-3-generic x86_64
  ApportVersion: 2.18-0ubuntu8
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Mon Aug 31 08:16:04 2015
  InstallationDate: Installed on 2015-08-11 (19 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150808)
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.1.0-3-generic root=UUID=ec35dce5-3920-4a9b-9de2-f3aab5aeba12 ro quiet splash vt.handoff=7
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/10/2011
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 5CKT69AUS
  dmi.board.name: LENOVO
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: NONE
  dmi.modalias: dmi:bvnLENOVO:bvr5CKT69AUS:bd01/10/2011:svnLENOVO:pn6234A1U:pvrThinkCentreM58p:rvnLENOVO:rnLENOVO:rvrNONE:cvnLENOVO:ct3:cvrNONE:
  dmi.product.name: 6234A1U
  dmi.product.version: ThinkCentre M58p
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: