← Back to team overview

kernel-packages team mailing list archive

[Bug 1189721] Re: Ralink RT3290 doesn't have a bluetooth driver


PLEASE help me.
I have Ubuntu 14.04.3 installed (kernel 3.19) and could not even get WiFi to work properly on this shitty card. Stock driver rt2800pci has very poor performance (very low signal and speed). I have tried installing and uninstalling ALL dkms packages from other bug report here:


but no success. WiFi disconnects very frequently and does not connect back again until reboot though when working for a few minutes works great.
Alexandre Magno, please help me and provide with a latest patch for WiFi support for RT3290 on Ubuntu 14.04 (kernel 3.19) or Linux Mint 17.2 (Kernel 3.16).

If you could also help me with Bluetooth that would be great. I tried
your patch by building .deb using Checkinstall but it failed pairing

Looking forward to your reply.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Ralink RT3290 doesn't have a bluetooth driver

Status in Linux:
Status in Linux Mint:
Status in linux package in Ubuntu:

Bug description:
  As of Raring Ubuntu has a wifi driver for the RT3290 that works out of
  the box.

  It still does not have bluetooth support.

  This thread in the Ubuntu forums links to a driver that is claimed to

  ApportVersion: 2.9.2-0ubuntu8.3
  Architecture: amd64
   /dev/snd/controlC0:  graeme     2412 F.... pulseaudio
   country GB:
   	(2402 - 2482 @ 40), (N/A, 20)
   	(5170 - 5250 @ 40), (N/A, 20)
   	(5250 - 5330 @ 40), (N/A, 20), DFS
   	(5490 - 5710 @ 40), (N/A, 27), DFS
  DistroRelease: Ubuntu 13.04
  EcryptfsInUse: Yes
  HibernationDevice: RESUME=UUID=2d107179-35e2-4b1f-8bdd-90a01132ec70
  InstallationDate: Installed on 2013-05-17 (144 days ago)
  InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
  MachineType: Hewlett-Packard HP ProBook 4540s
  MarkForUpload: True
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-31-generic root=UUID=ac74fd89-3445-4a6d-b91b-ae4987867afe ro quiet splash acpi_backlight=vendor vt.handoff=7
  ProcVersionSignature: Ubuntu 3.8.0-31.46-generic
   linux-restricted-modules-3.8.0-31-generic N/A
   linux-backports-modules-3.8.0-31-generic  N/A
   linux-firmware                            1.106
   0: phy0: Wireless LAN
   	Soft blocked: no
   	Hard blocked: no
  Tags:  raring
  Uname: Linux 3.8.0-31-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo
  dmi.bios.date: 11/06/2012
  dmi.bios.vendor: Hewlett-Packard
  dmi.bios.version: 68IRR Ver. F.32
  dmi.board.name: 17F6
  dmi.board.vendor: Hewlett-Packard
  dmi.board.version: KBC Version 58.1D
  dmi.chassis.type: 10
  dmi.chassis.vendor: Hewlett-Packard
  dmi.modalias: dmi:bvnHewlett-Packard:bvr68IRRVer.F.32:bd11/06/2012:svnHewlett-Packard:pnHPProBook4540s:pvrA1018C1100:rvnHewlett-Packard:rn17F6:rvrKBCVersion58.1D:cvnHewlett-Packard:ct10:cvr:
  dmi.product.name: HP ProBook 4540s
  dmi.product.version: A1018C1100
  dmi.sys.vendor: Hewlett-Packard

To manage notifications about this bug go to: