← Back to team overview

kernel-packages team mailing list archive

[Bug 1490130] Re: Elantech touchpad stops working after suspend


My colleague found this on a similar laptop, I suspect it is the same
issue: http://marc.info/?l=linux-input&m=144312209020616&w=2

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Elantech touchpad stops working after suspend

Status in linux package in Ubuntu:

Bug description:
  i have asus a455ld i5 5200u running kubuntu 15.04 with kernel 4.0.8-040008-generic. 
  touchpad is recognized as elantech version 4. everything was fine until my notebook go to suspend and resume without touchpad working.
  I tried :
  modprobe -r psmouse
  modprobe psmouse

  it only work before suspend.
  execute those commands after resume from suspend is not working.

  the last thing i tried is this.

  when i use this command before suspend :


  these appear in the dmesg:

  [  820.207105] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x381f00)
  [  820.222270] psmouse serio1: elantech: Synaptics capabilities query result 0x10, 0x14, 0x0e.
  [  820.294698] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input146

  but when i use the command after suspend, there is nothing any output
  in the dmesg.

  i tried all ubuntu varian and opensuse 13.2 live usb, the result is the same. 
  but in windows 10,  touchpad still active after suspend.
  ApportVersion: 2.17.2-0ubuntu1.3
  Architecture: amd64
  CurrentDesktop: MATE
  DistroRelease: Ubuntu 15.04
  InstallationDate: Installed on 2015-06-20 (69 days ago)
  InstallationMedia: Kubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  Package: linux (not installed)
  Tags:  vivid
  Uname: Linux 4.0.8-040008-generic x86_64
  UnreportableReason: The running kernel is not an Ubuntu kernel
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm bumblebee cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True

To manage notifications about this bug go to: