← Back to team overview

kernel-packages team mailing list archive

[Bug 1494236] Re: 10de:1292 Optirun does not run as kernel does not recognise 3D Controller NVIDIA


I tried kernel v4.3-rc4, however I was unable to get bumblebee to run as
the nvidia driver was not supported. (It booted, but bumblebeed would
not start as there was no valid nvidia driver)

from /var/log/syslog

    Oct  5 22:32:27 flat systemd[1]: bumblebeed.service holdoff time over, scheduling restart.
    Oct  5 22:32:27 flat systemd[1]: Started Bumblebee C Daemon.
    Oct  5 22:32:27 flat systemd[1]: Starting Bumblebee C Daemon...
    Oct  5 22:32:27 flat bumblebeed[5208]: [  128.914578] [ERROR]Module 'nvidia_340_updates' is not found.
    Oct  5 22:32:27 flat systemd[1]: bumblebeed.service: main process exited, code=exited, status=1/FAILURE
    Oct  5 22:32:27 flat systemd[1]: Unit bumblebeed.service entered failed state.
    Oct  5 22:32:27 flat systemd[1]: bumblebeed.service failed.

I tried the steps as suggested here


but was unable to get a working nvidia driver in the 4.3 kernel. This
included using

    root@flat:~# export IGNORE_CC_MISMATCH=1

to try and force it to install.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  10de:1292 Optirun does not run as kernel does not recognise 3D
  Controller NVIDIA

Status in linux package in Ubuntu:

Bug description:
  $ lspci -nn
  00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 09)
  04:00.0 3D controller [0302]: NVIDIA Corporation GK208M [GeForce GT 740M] [10de:1292] (rev ff)

  $ dmesg | fgrep vgaar
  [ 0.243143] vgaarb: setting as boot device: PCI:0000:00:02.0
  [ 0.243145] vgaarb: device added: PCI:0000:00:02.0,decodes=io+mem,owns=io+mem,locks=none
  [ 0.243150] vgaarb: loaded
  [ 0.243152] vgaarb: bridge control possible 0000:00:02.0
  [ 2.766514] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem
  [ 2336.771620] vgaarb: this pci device is not a vga device
  [ 2337.170566] vgaarb: this pci device is not a vga device
  [ 2415.373308] vgaarb: this pci device is not a vga device
  [ 2415.734668] vgaarb: this pci device is not a vga device

  $ uname -a
  Linux flat 3.19.0-26-generic #28-Ubuntu SMP Tue Aug 11 14:16:32 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: linux-image-3.19.0-26-generic 3.19.0-26.28
  ProcVersionSignature: Ubuntu 3.19.0-26.28-generic 3.19.8-ckt4
  Uname: Linux 3.19.0-26-generic x86_64
  ApportVersion: 2.17.2-0ubuntu1.3
  Architecture: amd64
   /dev/snd/controlC0:  grumpy     2187 F.... pulseaudio
   /dev/snd/controlC1:  grumpy     2187 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Thu Sep 10 20:11:34 2015
  HibernationDevice: RESUME=UUID=0f0470a9-ab37-4ceb-b408-3ff836a8ed03
  InstallationDate: Installed on 2015-05-19 (114 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
   Bus 003 Device 002: ID 8087:8000 Intel Corp. 
   Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 002: ID 0bda:5606 Realtek Semiconductor Corp. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-26-generic.efi.signed root=UUID=6dbeeb75-7225-4474-8a0f-5b0447421785 ro quiet splash vt.handoff=7
   linux-restricted-modules-3.19.0-26-generic N/A
   linux-backports-modules-3.19.0-26-generic  N/A
   linux-firmware                             1.143.3
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 11/19/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: X550LB.402
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: X550LB
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: ATN12345678901234567
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX550LB.402:bd11/19/2013:svnASUSTeKCOMPUTERINC.:pnX550LB:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX550LB:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.name: X550LB
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.

To manage notifications about this bug go to: