← Back to team overview

kernel-packages team mailing list archive

[Bug 24776] BootDmesg.txt


apport information

** Attachment added: "BootDmesg.txt"

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  ipw2100 - "Fatal interrupt. Scheduling firmware restart."

Status in Linux:
Status in linux package in Ubuntu:
Status in linux-source-2.6.22 package in Baltix:
Status in linux package in Fedora:

Bug description:
  /**** ATTENTION ****
  I believe this issue is specific to the error that a chipset that is not 802.11G capable will return when it picks up an a beacon from a router that is not mixed-mode, but 802.11G specific. Please verify. Remove mixed-mode from your G routers, and see if you can get this repeated. Then add back mix mode and see if it goes away and if you're connected with 802.11B.

  [ Current Status ]

  The ipw2100 driver was last updated on 2007-01-31.  That tarball
  release contained an issues file that described this particular bug:

  Firmware restart is detected randomly

  After running one or two days, Intel PRO/Wireless 2100 Network Connection
  driver will only occasionally restart the firmware.
  "ipw2100: Fatal interrupt. Scheduling firmware restart"

  To resolve this problem, the system must be rebooted.

  Defect #329

  [ Original Description ]
  Since I've upgrade to Breezy, ipw2100 driver no longer works and in dmesg I've
  got plenty 
  "Fatal interrupt. Scheduling firmware restart."

  I'm always able to do an iwlist :

  % sudo iwlist eth1 scanning
  eth1      Scan completed :
            Cell 02 - Address: 00:07:CB:51:65:E0
                      Protocol:IEEE 802.11b
                      Encryption key:on
                      Bit Rate:11 Mb/s
                      Extra: Rates (Mb/s): 1 2 5.5 11
                      Quality=92/100  Signal level=-36 dBm
                      Extra: Last beacon: 31ms ago

  But the card no longer register. It stays "unassociated" whatever I've
  tried :

  % sudo iwconfig eth1 essid gaspard key open XXXXXXXXXX mode auto
  % sudo iwconfig eth1
  eth1      unassociated  ESSID:"gaspard"  Nickname:"ipw2100"
            Mode:Managed  Channel=0  Access Point: 00:00:00:00:00:00
            Bit Rate=0 kb/s   Tx-Power:off
            Retry min limit:7   RTS thr:off   Fragment thr:off
            Encryption key:4D7E-7ED3-1D   Security mode:open
            Power Management:off
            Link Quality:0  Signal level:0  Noise level:0
            Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
            Tx excessive retries:0  Invalid misc:0   Missed beacon:0

  Sometimes, it works for a short time and after half an hour or an hour, it crash

  I've tried to upgrade ipw2100 and the firmware. No way.

To manage notifications about this bug go to: