← Back to team overview

kernel-packages team mailing list archive

[Bug 1507994] Re: Broadwell vaapi video decode broken by i915_bpo migration


Ok, then how to get mpv use vaapi? Trying 'mpv --hwdec=vaapi --vo
=opengl-hq' as suggested somewhere still results in software decoding
according to the debug output. Tried big buck bunny 1080p avi and 720p

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Broadwell vaapi video decode broken by i915_bpo migration

Status in linux package in Ubuntu:
Status in linux source package in Vivid:
Status in linux source package in Wily:

Bug description:
  Since upgrading from linux-image-3.19.0-28-generic to linux-
  image-3.19.0-30-generic, vaapi-accelerated video playback on Kodi 15.2
  (and 15.1) is now all black.

  On-screen display items (eg. elapsed time) and audio still work, but
  the decoded video content is now all black. Disabling vaapi
  acceleration in the Kodi options restores the video playback.

  I have bisected the problem to this commit:

  The problem still happens in Ubuntu-3.19.0-31.36, as well as
  Ubuntu-4.0.0-1.2 and Ubuntu-4.2.0-16.19 from the ubuntu-wily repo.

  It appears that the above commit flicks the switch on many changes,
  and doesn't really shed too much light on what the actual problem
  might be.

  I've tried moving that commit earlier into the history in the hope
  that I might be able to find a 'good' point to bisect from, but had no
  luck. The furthest I was able to push it back was
  vivid.git/commit/?id=59b6d9aaa4c379d84930598183cb4911a2713ff4, but the
  problem remained.

  ProblemType: Bug
  DistroRelease: Ubuntu 15.04
  Package: linux-image-3.19.0-30-generic 3.19.0-30.34
  ProcVersionSignature: Ubuntu 3.19.0-30.34-generic 3.19.8-ckt6
  Uname: Linux 3.19.0-30-generic x86_64
  ApportVersion: 2.17.2-0ubuntu1.5
  Architecture: amd64
   /dev/snd/controlC0:  sdt        1916 F.... kodi.bin
  Date: Tue Oct 20 21:39:48 2015
  InstallationDate: Installed on 2015-05-03 (170 days ago)
  InstallationMedia: Ubuntu-Server 14.10 "Utopic Unicorn" - Release amd64 (20141022.2)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-30-generic.efi.signed root=UUID=fb2f2c21-efe7-405c-b354-4a462517f241 ro
   linux-restricted-modules-3.19.0-30-generic N/A
   linux-backports-modules-3.19.0-30-generic  N/A
   linux-firmware                             1.143.3
  RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
  SourcePackage: linux
  UpgradeStatus: Upgraded to vivid on 2015-05-03 (170 days ago)
  dmi.bios.date: 08/12/2015
  dmi.bios.vendor: Intel Corporation
  dmi.bios.version: RYBDWi35.86A.0350.2015.0812.1722
  dmi.board.name: NUC5i3RYB
  dmi.board.vendor: Intel Corporation
  dmi.board.version: H41000-502
  dmi.chassis.type: 3
  dmi.modalias: dmi:bvnIntelCorporation:bvrRYBDWi35.86A.0350.2015.0812.1722:bd08/12/2015:svn:pn:pvr:rvnIntelCorporation:rnNUC5i3RYB:rvrH41000-502:cvn:ct3:cvr:

To manage notifications about this bug go to: