← Back to team overview

kernel-packages team mailing list archive

[Bug 1509666] Re: I cannot mount nfs shares from osx when using the new kernel


Thanks for taking the time to look at this, and sorry to have missed
that my BIOS was out of date. I have now flashed the new version and
running the commands as you propose gives the following output:

nick@serv2:~$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
[sudo] password for nick: 

Also, I confirm that updating the  BIOS has not solved the problem.

If I understand your question correctly, you are asking for how the bug
manifests itself? If so, I have the following two files set up on my MAC
to allow me to automount the share:

beethoven:etc nick$ cat auto_master
# Automounter master map
+auto_master		# Use directory service
/net			-hosts		-nobrowse,hidefromfinder,nosuid
/home			auto_home	-nobrowse,hidefromfinder
/Network/Servers	-fstab
/-			-static
/-	auto_nfs	-nobrowse,nosuid


beethoven:etc nick$ cat auto_nfs
/../Volumes/share	-fstype=nfs,noresvport	nfs://serv2_local:/export/share

Note for completeness, serv2_local is defined in my /etc/hosts file:
beethoven:etc nick$ cat /etc/hosts
# Host Database
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##	localhost	broadcasthost
::1             localhost 
fe80::1%lo0	localhost	serv2_local

(and that I have a good connection to it:
beethoven:etc nick$ ping serv2_local
PING serv2_local ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=4.572 ms

The use of /../Volumes/share is a trick to make OSX automount in the
/Volumes directory. I have tested using /mnt/share and get the same

serv2_local is also correctly exporting the nfs shares:
beethoven:etc nick$ showmount -e serv2_local
Exports list on serv2_local:

(note that the MAC I am using has IP address so it should
be able to access the export)

When I try to access the shared directory, I get the following:
beethoven:Volumes nick$ cd /Volumes
beethoven:Volumes nick$ ls -lh
total 10
lrwxr-xr-x  1 root  admin     1B 24 Oct 17:13 Macintosh HD -> /
dr-xr-xr-x  2 root  wheel     1B 24 Oct 17:13 share
beethoven:Volumes nick$ cd share
-bash: cd: share: No such file or directory

If I boot the Ubuntu server with the pervious kernel version, I am able to access the NFS share normally.

Thanks for taking your time to look at this -- let me know if you need
more information.

** Changed in: linux (Ubuntu)
       Status: Incomplete => Confirmed

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  I cannot mount nfs shares from osx when using the new kernel

Status in linux package in Ubuntu:

Bug description:
  I am running ubuntu server 64 bit 14.04 on my home server.
  The server shares some directories using NFS v4

  I have some apple macs (MBAs) that use the automount to mount the shared nfs directory. Previously, this had worked fine.
  My file /etc/auto_nfs contains the single line:
  /../Volumes/share	-fstype=nfs,noresvport	nfs://serv2_local:/export/share

  I updated to kernel 3.13.0-66 and the OSX machines would no long mount
  the NFS shares (see message below from /var/log/messages.log on the

  Oct 24 14:34:35 beethoven automountd[655]: NFS server serv2_local not

  Please see the list of modules loaded:
  Oct 24 14:26:36 serv2 kernel: [   36.402674] Modules linked in: quota_v2 quota_tree nfsd auth_rpcgss nfs_acl nfs lockd sunrpc fscache dm_crypt rc_dvbsky(OX) xt_tcpudp xt_recent iptable_filter ip_tables x_tables snd_hda_codec_realtek dvbsky_m88rs6000(OX) snd_hda_intel snd_hda_codec kvm_amd snd_hwdep smipcie(OX) dvb_core(OX) kvm snd_pcm rc_core(OX) snd_page_alloc snd_timer snd soundcore serio_raw i2c_piix4 edac_core edac_mce_amd k10temp shpchp mac_hid parport_pc ppdev lp parport pata_acpi hid_generic usbhid radeon hid i2c_algo_bit ttm drm_kms_helper pata_atiixp ahci libahci atl1c drm wmi

  My other linux clients were able to mount the NFS share without difficulty. I have rolled the server back to the previous kernel (3.13.0-65-generic) and NFS works fine with the Macs. (Note that the problem exists with both my Macs, running OSX 10.10.5 and 10.11.1)
  AlsaVersion: Advanced Linux Sound Architecture Driver Version k3.13.0-66-generic.
  AplayDevices: Error: [Errno 2] No such file or directory
  ApportVersion: 2.14.1-0ubuntu3.16
  Architecture: amd64
  ArecordDevices: Error: [Errno 2] No such file or directory
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', '/dev/snd/controlC0', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/pcmC0D2c', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
  CRDA: Error: [Errno 2] No such file or directory
  Card0.Amixer.info: Error: [Errno 2] No such file or directory
  Card0.Amixer.values: Error: [Errno 2] No such file or directory
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=f0e7e97e-cfde-42f5-a6a8-33d670d4f6ad
  InstallationDate: Installed on 2015-07-25 (91 days ago)
  InstallationMedia: Ubuntu-Server 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
   lo        no wireless extensions.
   p5p1      no wireless extensions.
  MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
  Package: linux (not installed)
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-66-generic root=UUID=cba0a062-b757-496a-a056-c284b18f961b ro nomodset
  ProcVersionSignature: Ubuntu 3.13.0-66.108-generic 3.13.11-ckt27
   linux-restricted-modules-3.13.0-66-generic N/A
   linux-backports-modules-3.13.0-66-generic  N/A
   linux-firmware                             1.127.15
  RfKill: Error: [Errno 2] No such file or directory
  Tags:  trusty
  Uname: Linux 3.13.0-66-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 10/02/2013
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P1.30
  dmi.board.asset.tag: BC5FF4ED68C6
  dmi.board.name: 960GM-VGS3 FX
  dmi.board.vendor: ASRock
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.30:bd10/02/2013:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rn960GM-VGS3FX:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: To Be Filled By O.E.M.
  dmi.product.version: To Be Filled By O.E.M.
  dmi.sys.vendor: To Be Filled By O.E.M.

To manage notifications about this bug go to: