← Back to team overview

kernel-packages team mailing list archive

[Bug 1482711] Re: X displays nothing instead of login screen


I know I took a long time again. My primary observation is that this bug
does not appear when the nvidia driver is not installed.

I tested the upstream kernel version that matches the most recent
repository kernel update(as well as the most recent upstream kernel
version) before installing the most recent repository kernel
update(3.13.11-031311ckt27 which the package manager calls
3.13.0-66.108). With both of the kernels from the upstream source, the
nvidia module failed to install, and neither exhibited the bug, but when
installed from the package manager the bug did occur in that same kernel

Unfortunately I don't know how to make the nvidia driver install for the
upstream kernels, if it is even possible, and thus cannot test them
properly. This is complicated by the fact that this bug appeared when
the package manager forced an update to the nvidia module from 331 which
supports my video card to 340 which makes no such claim.

Other than the nvidia driver not installing, the upstream kernels worked
fine, though with a lot of warnings when I booted them, all about
apparmor rules not being enforced. If you want, I ran a dmesg with each
of them booted into a file, but I hesitate to post them, and thus
pollute the associated data without your say so.

Given this information I fully expect that the answer here is either,
"go report this to ___ instead of here.", "Sorry but your hardware is
not supported by the newer kernel versions. Have a nice day." or
possibly a "Well, see if it happens with the repository kernels if you
uninstall the ndivia drivers." (I made a half hearted attempt to do that
even before I posted this bug, but I didn't figure out how to tell the
package manager to uninstall all the nvidia drivers without trying to
install some random other version.)

Another thing that might provide some clues: some time ago I had installed the CUDA develpoment tools, and made a simple test
program. On the version of the kernel for which the desktop works, that CUDA program will not run (it says that there is no device), however, when switched over to a virtual terminal from the blank screen caused by the bug, the program runs just fine. This tells me that perhaps the bug isn't occurring for this kernel version because the nvidia driver isn't working for it.

So I hope this is somewhat useful even though technically the response
is unable to test upstream. As per the instructions I will mark it as
confirmed again. I hope that that is the right thing to do, even though
I wasn't really able to test what you wanted well.

** Changed in: linux (Ubuntu)
       Status: Incomplete => Confirmed

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  X displays nothing instead of login screen

Status in linux package in Ubuntu:

Bug description:
  The kernel version in the auto-generated information is wrong, because
  when using the kernel with the problem, I can't do anything, including
  send bug reports. This happened with the newest kernel update to
  3.13.0-61. I am using -59, which still works, to send the report.
  Since this is at least possibly graphics related bug I should also
  state that the update automatically changed the nvidia driver from
  331-updates to 340-updates, however Nvidia's page for the 340 driver
  does not include my graphics card (GeForce 610M). I do use

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: linux-image-3.13.0-59-generic 3.13.0-59.98
  ProcVersionSignature: Ubuntu 3.13.0-59.98-generic 3.13.11-ckt22
  Uname: Linux 3.13.0-59-generic i686
  ApportVersion: 2.14.1-0ubuntu3.11
  Architecture: i386
   /dev/snd/controlC0:  trun       2629 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Fri Aug  7 09:22:29 2015
  HibernationDevice: RESUME=UUID=6d121e03-2523-4564-ab73-f600c35a6142
  InstallationDate: Installed on 2014-11-23 (256 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release i386 (20140722.2)
   Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
   Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 001 Device 003: ID 1bcf:288a Sunplus Innovation Technology Inc. 
   Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Acer Aspire 7739G
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.13.0-59-generic root=/dev/mapper/vg_hydra-lv_root ro noplymouth
   linux-restricted-modules-3.13.0-59-generic N/A
   linux-backports-modules-3.13.0-59-generic  N/A
   linux-firmware                             1.127.14
  SourcePackage: linux
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 10/11/2011
  dmi.bios.vendor: Insyde Corp.
  dmi.bios.version: V1.04
  dmi.board.asset.tag: Type2 - Board Asset Tag
  dmi.board.name: HMA71_CP
  dmi.board.vendor: Acer
  dmi.board.version: Type2 - Board Version
  dmi.chassis.type: 10
  dmi.chassis.vendor: Chassis Manufacturer
  dmi.chassis.version: Chassis Version
  dmi.modalias: dmi:bvnInsydeCorp.:bvrV1.04:bd10/11/2011:svnAcer:pnAspire7739G:pvrV1.04:rvnAcer:rnHMA71_CP:rvrType2-BoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
  dmi.product.name: Aspire 7739G
  dmi.product.version: V1.04
  dmi.sys.vendor: Acer

To manage notifications about this bug go to: