← Back to team overview

kernel-packages team mailing list archive

[Bug 1240940] Re: Need support for Realtek Wifi card rtl8723be [10ec:b723]



I'm experiencing the same issue as @avirup-das. I have the RTL8723BE on
my HP Stream 11. I verified the wifi works great in Windows (8) so the
internal card is okay.

Using Xubuntu-amd64 15.10 with new installed kernel 4.3.0 (same results
as in kernel 4.2.0)

Wifi does work and the laptop connects to the network, but my wireless
controller reports a very weak signal from my laptop. Ubuntu also
reports a weak signal with connection to the AP. I can only connect to
wifi when sitting next to the AP. (All my other devices can connect fine
from a certain distance from the AP.)

Signal is stable (very near the AP) when sitting in the same place and
there's no interference. Bandwidth/speed is between 1kb/sec and
100kb/sec max.

 # iwlist wlo1 txpower
returns Tx-Power at 20dBm (100mW), so that seems okay.

I've tried;
- Using newest lwfinger git driver: Getting the above results
- With and without the modprobe config options (tried on and off 'ips', 'msi', 'fwlps' and 'swlps'): "msi:Y" results in no connection, msi:N does give above results. No difference setting other options.
- Use ndiswrapper to use Windows drivers for this card: This doesn't change anything to the above.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Need support for Realtek Wifi  card rtl8723be [10ec:b723]

Status in HWE Next:
  Fix Released
Status in HWE Next trusty series:
  Fix Released
Status in linux package in Ubuntu:
  Fix Released
Status in linux source package in Trusty:
  Fix Released

Bug description:
  This device is appearing in some OEM machines, but driver is not yet
  available upstream.

  This bug is only for the initial support of this WiFi adapter, it's
  not working 100% well yet, please report new "not working bug" or
  contact upstream but not keep posting comments, thanks.

To manage notifications about this bug go to: