← Back to team overview

kernel-packages team mailing list archive

[Bug 1512266] Re: Xubuntu. Plymouth breaks after upgrade from 14.04.0 to 14.04.3


This is almost certainly not an issue with plymouth, but with the
kernel.  There were regressions recently reported against the SRUed
kernel in vivid, which would also apply to the hwe-vivid kernel.

Bear in mind that for a system whose hardware already functions properly
with the 14.04.0 kernel, it is not generally recommended to switch to a
hardware enablement stack.

** Package changed: plymouth (Ubuntu) => linux (Ubuntu)

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Xubuntu. Plymouth breaks after upgrade from 14.04.0 to 14.04.3

Status in linux package in Ubuntu:

Bug description:
  Guide to update from 14.04.0 to 14.04.3 breaks Plymouth at Xubuntu.

  I have tried this with Xubuntu 14.04 several times with the same
  result. Always updated 64-bit systems from a minimal CD, if it
  matters. I do not use any proprietary drivers, and have been using two
  different hardwares.

  From this site: https://wiki.ubuntu.com/Kernel/LTSEnablementStack
  I have followed this instruction: sudo apt-get install --install-recommends linux-generic-lts-vivid xserver-xorg-core-lts-vivid xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid xserver-xorg-input-all-lts-vivid libwayland-egl1-mesa-lts-vivid.


  What I expect to happen
  I expect  the system to boot normally, and ask for the password in the gui as usual. 

  What do happen?
  Plymouth breaks when using an Luks encrypted drive. It turns off the screen (“no signal”) instead of asking for password. (Workaround, press ESC to change to text mode. Then the screen turns on again in text mode.) I have not tried this out with an unencrypted disk.

  I GUESS that LUKS is not involved in itself, but stops the boot at the
  same time as  Plymouth breaks, and makes it far more distracting.

  I have got the same problem on Ubuntu-Mate, but I don't know if more
  official flavors are affected.

  Xubuntu version 14.04.3 natively uses the vivid x stack and kernel, so
  it is already solved somewhere else.

To manage notifications about this bug go to: