← Back to team overview

kernel-packages team mailing list archive

[Bug 1516215] Status changed to Confirmed


This change was made by a bot.

** Changed in: linux (Ubuntu)
       Status: New => Confirmed

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

   kernel 4.x has issues with lite-on sata controller in dell xps 13

Status in linux package in Ubuntu:

Bug description:

  I have a Dell XPS 13 (2015) which has a Lite-On Sata controller:

  03:00.0 SATA controller: Lite-On Technology Corporation Device 0224
  (rev 10)

  Right from the beginning, I have issues with that one under Linux
  (windows is just fine, so hardware seems to be ok). It might happen
  that the notebook just dies (loosing its SSD), or it might not even
  boot. Whenever it does not boot, it usually stops with a message
  around "job 1 of 12 ..." (I don't find them in any logs ). It can help
  to boot Windows and reboot into Linux, but that is not always the
  case. It usually helps to boot a 3.19.x kernel, although even that one
  can have the same issues (although way less than 4.x).

  The system almost always crashes completely when I run the dump tool.

  BIOS is on newest version (A05).

  Would someone have any hints on how move forward? Maybe where to find
  more debug output ? Or is there even a solution?

  I already asked on launchpad
  https://answers.launchpad.net/ubuntu/+question/274153 and was asked to
  file a bug.

  best regards

  More info as requested for filing bugs

  1) I ran ubuntu-bug linux (see report attached)

  2) lsb_release -rd
  Description:	Ubuntu 15.10
  Release:	15.10

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-18-generic 4.2.0-18.22
  ProcVersionSignature: Ubuntu 4.2.0-18.22-generic 4.2.3
  Uname: Linux 4.2.0-18-generic x86_64
  ApportVersion: 2.19.1-0ubuntu4
  Architecture: amd64
   /dev/snd/controlC0:  latze      1599 F.... pulseaudio
  CurrentDesktop: XFCE
  Date: Sat Nov 14 09:29:04 2015
  HibernationDevice: RESUME=UUID=b8662265-a1f0-487e-9d85-2731c765b3eb
  InstallationDate: Installed on 2015-08-23 (82 days ago)
  InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422.1)
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 0bda:5682 Realtek Semiconductor Corp. 
   Bus 001 Device 003: ID 04f3:20d0 Elan Microelectronics Corp. 
   Bus 001 Device 002: ID 8087:0a2a Intel Corp. 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: Dell Inc. XPS 13 9343
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-18-generic.efi.signed root=UUID=9e67912b-c59e-47ac-b2f1-3ef39e3d38fb ro debug
   linux-restricted-modules-4.2.0-18-generic N/A
   linux-backports-modules-4.2.0-18-generic  N/A
   linux-firmware                            1.149.1
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: Upgraded to wily on 2015-10-31 (13 days ago)
  dmi.bios.date: 07/14/2015
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A05
  dmi.board.name: 0310JH
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvrA05:bd07/14/2015:svnDellInc.:pnXPS139343:pvr:rvnDellInc.:rn0310JH:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: XPS 13 9343
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: