← Back to team overview

kernel-packages team mailing list archive

[Bug 1516547] Re: Ubuntu 15.10 crashes with RAID-10


We've located the issue to be somewhere in the RAID rebuilding process.

Turning down the RAID rebuild speed with the command "echo 1 >
/proc/sys/dev/raid/speed_limit_max" will make the installation success
but this is only pushing the crash for later in the OS.

We've also noticed when installing without RAID an installation takes
about 15 minutes. With RAID it can take up to one hour as it seems like
the RAID rebuild is lacking the install process. This isn't experienced
in Ubuntu 15.04.

It's not possible the see the same errors from the screenshots in syslog
probably because the system is unable to respond and read/write to the
disk. Also when trying to login from the terminal the server just hangs
after entering username.

We'll try to test with kernel 4.3.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Ubuntu 15.10 crashes with RAID-10

Status in linux package in Ubuntu:

Bug description:
  When trying to install Ubuntu 15.10 with a RAID-10 created the system
  crashes after some time during the installation. Hitting Alt+F4 gives
  the following output as seen from screenshots in attachments.

  It looks like kernel 4.2 have some issues with RAID-10 as we can
  install Ubuntu 15.04 (with kernel 3.19) without problems. If we
  upgrade to kernel 4.2 in Ubuntu 15.04 we get the same errors.

  We have no problems when installing without RAID, RAID-0 or RAID-1.
  We've also tried on different hardware and different disk types/sizes
  but we still get system crash.

To manage notifications about this bug go to: