← Back to team overview

kernel-packages team mailing list archive

[Bug 1514052] Re: erratic fan speed and little control kernel 4.2


Peter Saunderson, could you please test the latest mainline kernel
(4.4-rc2+cod1) and advise to the results?

** Tags removed: needs-bisect
** Tags added: bisect-done

** Tags added: kernel-bug-exists-upstream-4.3

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  erratic fan speed and little control kernel 4.2

Status in linux package in Ubuntu:

Bug description:
  I have just upgraded to Ubuntu 15.10 and almost immediately my CPU fan
  started speeding and slowing without good reason even when the PC is

  I tried various things but then found that if I leave the computer off
  for a long time and let everything cool down then when I boot from
  cold the CPU fan is stable.

  To test my theory of cold start out I then ran
  sudo cpupower frequency-set -g powersave
  followed by
  sudo cpupower frequency-set -g ondemand

  The final mode is the initial mode.  Almost immediately as soon as I
  moved to powersave mode the erratic fan speed started.  It did not
  stop when I returned to ondemand.

  Temp fix for this behaviour is - go and have a cup of coffee and let
  the computer cool down when you restart: shutdown then start from

  $ cpupower frequency-info
  analyzing CPU 0:
    driver: acpi-cpufreq
    CPUs which run at the same hardware frequency: 0
    CPUs which need to have their frequency coordinated by software: 0
    maximum transition latency: 10.0 us.
    hardware limits: 1.20 GHz - 2.80 GHz
    available frequency steps: 2.80 GHz, 2.80 GHz, 2.67 GHz, 2.53 GHz, 2.40 GHz, 2.27 GHz, 2.13 GHz, 2.00 GHz, 1.87 GHz, 1.73 GHz, 1.60 GHz, 1.47 GHz, 1.33 GHz, 1.20 GHz
    available cpufreq governors: conservative, ondemand, userspace, powersave, performance
    current policy: frequency should be within 1.20 GHz and 2.80 GHz.
                    The governor "ondemand" may decide which speed to use
                    within this range.
    current CPU frequency is 1.20 GHz.
    cpufreq stats: 2.80 GHz:11.93%, 2.80 GHz:0.00%, 2.67 GHz:0.40%, 2.53 GHz:0.44%, 2.40 GHz:0.51%, 2.27 GHz:0.55%, 2.13 GHz:0.35%, 2.00 GHz:0.72%, 1.87 GHz:0.84%, 1.73 GHz:1.00%, 1.60 GHz:2.16%, 1.47 GHz:4.61%, 1.33 GHz:16.83%, 1.20 GHz:59.65%  (29241)
    boost state support:
      Supported: yes
      Active: yes
      25500 MHz max turbo 4 active cores
      25500 MHz max turbo 3 active cores
      25500 MHz max turbo 2 active cores
      25500 MHz max turbo 1 active cores

  Tried intel_pstate but it is not supported for some reason on my
  machine ie the following does not work and I am left with driver:

  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_pstate=enable"

  Could not see ACPI Thermal Zones reported in dmesg
  $ dmesg | grep ACPI

  ApportVersion: 2.19.1-0ubuntu4
  Architecture: amd64
   /dev/snd/controlC0:  pas        2076 F.... pulseaudio
   /dev/snd/controlC1:  pas        2076 F.... pulseaudio
  CurrentDesktop: Unity
  DistroRelease: Ubuntu 15.10
  HibernationDevice: RESUME=UUID=68ce068c-1889-4f00-9b8a-12d7dc64348b
  InstallationDate: Installed on 2011-02-22 (1718 days ago)
  InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
   eth0      no wireless extensions.

   lo        no wireless extensions.
  MachineType: Dell Inc. Inspiron 580
  Package: linux (not installed)
  ProcFB: 0 radeondrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-17-generic root=UUID=bf510382-4d2b-49d6-b9d9-ac6e3f6334eb ro intel_pstate=enable
  ProcVersionSignature: Ubuntu 4.2.0-17.21-generic 4.2.3
   linux-restricted-modules-4.2.0-17-generic N/A
   linux-backports-modules-4.2.0-17-generic  N/A
   linux-firmware                            1.149.1

  Tags:  wily
  Uname: Linux 4.2.0-17-generic x86_64
  UpgradeStatus: Upgraded to wily on 2015-11-06 (0 days ago)
  UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare vboxusers wireshark
  _MarkForUpload: True
  dmi.bios.date: 11/13/2010
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A07
  dmi.board.name: 0C2KJT
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 3
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvrA07:bd11/13/2010:svnDellInc.:pnInspiron580:pvr:rvnDellInc.:rn0C2KJT:rvrA00:cvnDellInc.:ct3:cvr:
  dmi.product.name: Inspiron 580
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: