← Back to team overview

kernel-packages team mailing list archive

[Bug 1522094] Re: WARNING: CPU: 0 PID: 233 at /build/linux-lts-vivid-pTjnAT/linux-lts-vivid-3.19.0/drivers/gpu/drm/i915/intel_crt.c:145 hsw_crt_pre_enable+0x7f/0x90 [i915]()


jcat, could you please test the latest upstream kernel available from
the very top line at the top of the page from http://kernel.ubuntu.com
/~kernel-ppa/mainline/?C=N;O=D (the release names are irrelevant for
testing, and please do not test the daily folder)? Install instructions
are available at https://wiki.ubuntu.com/Kernel/MainlineBuilds . This
will allow additional upstream developers to examine the issue.

If the latest kernel did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this issue is fixed in the mainline kernel, please add the following tags by clicking on the yellow circle with a black pencil icon, next to the word Tags, located at the bottom of the report description:

Where X, and Y are the first two numbers of the kernel version, and Z is
the release candidate number if it exists.

If the mainline kernel does not fix the issue, please add the following tags:

Please note, an error to install the kernel does not fit the criteria of

Once testing of the latest upstream kernel is complete, please mark this
report's Status as Confirmed. Please let us know your results.

Thank you for your understanding.

** Tags removed: bios-outdated-a16
** Tags added: latest-bios-a16

** Changed in: linux (Ubuntu)
   Importance: Low => Medium

** Changed in: linux (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  WARNING: CPU: 0 PID: 233 at /build/linux-lts-vivid-pTjnAT/linux-lts-
  hsw_crt_pre_enable+0x7f/0x90 [i915]()

Status in linux package in Ubuntu:

Bug description:
  When I connect a monitor the VGA port on the laptop - this is found in
  dmesg, and some of the kernel modules linked in become unstable [
  btrfs for instance, if it's in use].

  [    2.962400] ------------[ cut here ]------------
  [    2.962424] WARNING: CPU: 0 PID: 233 at /build/linux-lts-vivid-pTjnAT/linux-lts-vivid-3.19.0/drivers/gpu/drm/i915/intel_crt.c:145 hsw_crt_pre_enable+0x7f/0x90 [i915]()
  [    2.962425] SPLL already enabled
  [    2.962426] Modules linked in: uas usb_storage hid_generic usbhid hid i915 psmouse i2c_algo_bit e1000e drm_kms_helper ahci libahci sdhci_pci drm ptp pps_core pata_acpi wmi sdhci_acpi video sdhci
  [    2.962437] CPU: 0 PID: 233 Comm: plymouthd Not tainted 3.19.0-37-generic #42~14.04.1-Ubuntu
  [    2.962438] Hardware name: Dell Inc. Latitude E6540/0PXPYJ, BIOS A15 05/19/2015
  [    2.962439]  ffffffffc02fd7f8 ffff880220d23ab8 ffffffff817af92b 0000000000003a7a
  [    2.962440]  ffff880220d23b08 ffff880220d23af8 ffffffff81074e0a 0000000000000046
  [    2.962442]  ffff880035fb0000 ffff88003615eb60 ffff880035f8f400 ffff88003615e800
  [    2.962444] Call Trace:
  [    2.962449]  [<ffffffff817af92b>] dump_stack+0x45/0x57
  [    2.962452]  [<ffffffff81074e0a>] warn_slowpath_common+0x8a/0xc0
  [    2.962453]  [<ffffffff81074e86>] warn_slowpath_fmt+0x46/0x50
  [    2.962464]  [<ffffffffc02b601f>] hsw_crt_pre_enable+0x7f/0x90 [i915]
  [    2.962475]  [<ffffffffc02a1a7c>] haswell_crtc_enable+0x3fc/0xaf0 [i915]
  [    2.962485]  [<ffffffffc029f1a2>] __intel_set_mode+0x872/0xc60 [i915]
  [    2.962495]  [<ffffffffc02a5af2>] intel_crtc_set_config+0x9e2/0xf60 [i915]
  [    2.962506]  [<ffffffffc010382f>] drm_mode_set_config_internal+0x6f/0x110 [drm]
  [    2.962511]  [<ffffffffc019e5c8>] restore_fbdev_mode+0xc8/0xf0 [drm_kms_helper]
  [    2.962515]  [<ffffffffc01a04e9>] drm_fb_helper_restore_fbdev_mode_unlocked+0x29/0x80 [drm_kms_helper]
  [    2.962525]  [<ffffffffc02b31ee>] intel_fbdev_restore_mode+0x1e/0x50 [i915]
  [    2.962536]  [<ffffffffc02d787e>] i915_driver_lastclose+0xe/0x20 [i915]
  [    2.962541]  [<ffffffffc00f6c4e>] drm_lastclose+0x2e/0x130 [drm]
  [    2.962546]  [<ffffffffc00f7088>] drm_release+0x338/0x540 [drm]
  [    2.962549]  [<ffffffff811ee077>] __fput+0xe7/0x220
  [    2.962551]  [<ffffffff811ee1fe>] ____fput+0xe/0x10
  [    2.962553]  [<ffffffff81091e3c>] task_work_run+0xac/0xd0
  [    2.962556]  [<ffffffff81015007>] do_notify_resume+0x97/0xb0
  [    2.962558]  [<ffffffff817b762f>] int_signal+0x12/0x17
  [    2.962559] ---[ end trace b6b778d930eaeda7 ]---

  This is the lts-vivid kernel.  downgrading to the lts-utopic kernel fixes the issue.
  I tried the wily-lts, same issue.

  I've also tried to recent kernels in http://kernel.ubuntu.com/~kernel-
  ppa :

  linux-image-4.3.0-040300-generic_4.3.0-040300 is still broken

  linux-image-4.4.0-040400rc3-generic_4.4.0-040400rc3.201511300321   works fine!  :)
  ApportVersion: 2.14.1-0ubuntu3.19
  Architecture: amd64
   /dev/snd/controlC0:  jcat       2559 F.... pulseaudio
   /dev/snd/controlC1:  jcat       2559 F.... pulseaudio
  CurrentDesktop: GNOME
  DistroRelease: Ubuntu 14.04
  HibernationDevice: RESUME=UUID=b338325d-c293-4b5b-ab0a-542a7f02236f
  InstallationDate: Installed on 2015-11-25 (8 days ago)
  InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
  MachineType: Dell Inc. Latitude E6540
  NonfreeKernelModules: fglrx
  Package: linux (not installed)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.19.0-39-generic.efi.signed root=UUID=8c468c94-323c-4526-b3a2-e1eddacbed42 ro quiet splash vt.handoff=7
  ProcVersionSignature: Ubuntu 3.19.0-39.44~14.04.1-generic 3.19.8-ckt9
   linux-restricted-modules-3.19.0-39-generic N/A
   linux-backports-modules-3.19.0-39-generic  N/A
   linux-firmware                             1.127.19
  Tags:  trusty
  Uname: Linux 3.19.0-39-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 05/19/2015
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: A15
  dmi.board.name: 0PXPYJ
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 9
  dmi.chassis.vendor: Dell Inc.
  dmi.modalias: dmi:bvnDellInc.:bvrA15:bd05/19/2015:svnDellInc.:pnLatitudeE6540:pvr01:rvnDellInc.:rn0PXPYJ:rvrA00:cvnDellInc.:ct9:cvr:
  dmi.product.name: Latitude E6540
  dmi.product.version: 01
  dmi.sys.vendor: Dell Inc.

To manage notifications about this bug go to: