← Back to team overview

kernel-packages team mailing list archive

[Bug 1379847] Re: macvlan doesn't work on the kernel 3.13.0-37-generic


DemonCcC, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:
apport-collect 1379847

When reporting bugs in the future please use apport by using 'ubuntu-
bug' and the name of the package affected. You can learn more about this
functionality at https://wiki.ubuntu.com/ReportingBugs.

** Package changed: linux-lts-trusty (Ubuntu) => linux (Ubuntu)

** Changed in: linux (Ubuntu)
   Importance: Undecided => Low

** Changed in: linux (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  macvlan doesn't work on the kernel 3.13.0-37-generic

Status in linux package in Ubuntu:

Bug description:
  I updated the kernel from linux-image-3.2.0-69-generic to linux-
  image-3.13.0-37-generic on Precise and the macvlan interface didn't
  work anymore.  I changed the kernel to linux-image-3.11.0-15-generic
  and it begins work again.

  Also I installed a new Trusty on other server and it doesn't work

  I set this interface on the servers because these servers are LXC
  hosts and I want to connect the host servers with the lxc guest
  servers (they are configured with macvlans interfaces).

  I have these settings on the /etc/network/interfaces:

  # The primary network interface
  auto eth0
  iface eth0 inet manual
  	up ifconfig eth0 up
  	down ifconfig eth0 down

  auto macvlan0
  iface macvlan0 inet static
  	pre-up ip link add link eth0 name macvlan0 address 06:00:a:3:3:3 type macvlan mode bridge
  	post-down ip link delete macvlan0

  I tried to debug the issue by using dmesg and checking the logs, but I
  didn't find any clue what is happening. I tried to find a bug about
  this issue, but I didn't have luck with that.

To manage notifications about this bug go to: