← Back to team overview

kernel-packages team mailing list archive

[Bug 1530557] Re: Random hard freezes under X on a laptop with Intel BayTrail processor (ASUS R752MA), Ubuntu 15.10



I have tried the newest available build from drm-intel-nightly, linux-
image-4.4.0-994-generic_4.4.0-994.201512302100_amd64.deb :

> cat /proc/cmdline 
BOOT_IMAGE=/boot/vmlinuz-4.4.0-994-generic root=UUID=dbe91b1d-f01e-4f19-85eb-3877b67143ac ro quiet splash vt.handoff=7

Unfortunately it just froze again, same as before, after about 45min of

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  Random hard freezes under X on a laptop with Intel BayTrail processor
  (ASUS R752MA), Ubuntu 15.10

Status in linux package in Ubuntu:

Bug description:
  System freezes hard when working under X, sometimes after minutes,
  sometimes after hours. Usually, but not always, graphics-intensive
  applications like viewing videos will trigger the hangs after a while,
  but they can also (much more rarely) occur when e.g. only an xterm is
  opened and being worked in under Unity.

  The MagicSysReq keys are not functional any more once the hang has
  occurred, there is no information in the logs, and no crash dump can
  be obtained by using the soft or nmi watchdogs, panic_on_oops etc.

  The BIOS was updated to the latest version available from ASUS:

  I have tried the latest mainline kernel build from
  http://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D , linux-
  (4.4-rc7), and the hangs still occur under the same circumstances.

  Some research has led me to
  https://bugzilla.kernel.org/show_bug.cgi?id=109051 , and I believe
  that it describes the exact problem I am experiencing. In particular,
  the workaround mentioned in there. adding the intel_idle.max_cstate=1
  kernel option, seems to work for me (and my machine is based on the
  Intel BayTrail, as mentioned in that report).

  (I am writing this report with this option with this enabled now, so
  don't be surprised to see it in the kernel command line).

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-22-generic 4.2.0-22.27
  ProcVersionSignature: Ubuntu 4.2.0-22.27-generic 4.2.6
  Uname: Linux 4.2.0-22-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
   /dev/snd/controlC0:  tmm        2184 F.... pulseaudio
  CurrentDesktop: Unity
  Date: Sat Jan  2 16:56:51 2016
  HibernationDevice: RESUME=UUID=f079f6d2-d58a-474c-ae48-d903be124a02
  InstallationDate: Installed on 2015-10-21 (72 days ago)
  InstallationMedia: Ubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-22-generic root=UUID=dbe91b1d-f01e-4f19-85eb-3877b67143ac ro quiet splash intel_idle.max_cstate=1 vt.handoff=7
   linux-restricted-modules-4.2.0-22-generic N/A
   linux-backports-modules-4.2.0-22-generic  N/A
   linux-firmware                            1.149.3
  SourcePackage: linux
  UpgradeStatus: Upgraded to wily on 2015-10-23 (71 days ago)
  dmi.bios.date: 08/10/2015
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: X751MA.403
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: X751MA
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrX751MA.403:bd08/10/2015:svnASUSTeKCOMPUTERINC.:pnX751MA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX751MA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.name: X751MA
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.

To manage notifications about this bug go to: