← Back to team overview

kernel-packages team mailing list archive

[Bug 1529356] Re: Bluetooth does not discover any device


Hello Jeremy,
Following your recommendation I updated to linux kernel  3.19.0-26.28
using :
sudo apt-get install linux-headers-3.19.0-26 linux-headers-3.19.0-26-generic linux-image-extra-3.19.0-26-generic --fix-missing

After a bluetooth it discovers the devices, displaying the names correctly only for my phone (one plus one).
But I can't pair to any device.
I tried to reinstall bluetooth drivers using :

sudo apt-get install --reinstall bluez bluez-alsa bluez-audio bluez-
btsco bluez-compat bluez-cups bluez-dbg bluez-gstreamer bluez-hcidump
bluez-pcmcia-support bluez-tools bluez-utils python-bluez bluewho
indicator-bluetooth libbluetooth-dev libgnome-bluetooth11 libbluetooth3
python-gobject python-dbus

I tried with and without ppa:hanipouspilot/rtlwifi linux-firmware
package. But still unable to pair.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  Bluetooth does not discover any device

Status in bluez package in Ubuntu:

Bug description:
  It looks like 
  but for an  Asus ROG G551JW

  I'm on ubuntu 14.04

  uname -a 
  3.19.0-25-generic #26~14.04.1-Ubuntu SMP Fri Jul 24 21:16:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

  Bus 004 Device 002: ID 8087:8000 Intel Corp. 
  Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  Bus 003 Device 002: ID 8087:8008 Intel Corp. 
  Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
  Bus 001 Device 003: ID 04f2:b3fd Chicony Electronics Co., Ltd 
  Bus 001 Device 004: ID 13d3:3474 IMC Networks 
  Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

  Seeing 13d3:3474 IMC Networks and searching in a search engine it seems to be an issue about AR3012 driver :
  I tried to update it using following ppa which should be providing the driver :

   sudo add-apt-repository ppa:hanipouspilot/rtlwifi
   sudo apt-get update
   sudo apt-get install linux-firmware

  ls /lib/firmware/ar3k/
  1020201coex                   ramps_0x01020200_40_0x03.dfu
  AthrBT_0x01020001.dfu         ramps_0x01020200_40_0x04.dfu
  AthrBT_0x01020200.dfu         ramps_0x01020200_40.dfu
  AthrBT_0x01020201.dfu         ramps_0x01020201_26_0x01.dfu
  AthrBT_0x11020000_ac01.dfu    ramps_0x01020201_26.dfu
  AthrBT_0x11020000.dfu         ramps_0x01020201_40_0x01.dfu
  AthrBT_0x11020100.dfu         ramps_0x01020201_40_0x02.dfu
  AthrBT_0x31010000.dfu         ramps_0x01020201_40_0x03.dfu
  AthrBT_0x31010100.dfu         ramps_0x01020201_40_0x04.dfu
  AthrBT_0x41020000.dfu         ramps_0x01020201_40.dfu
  ramps_0x01020001_26.dfu       ramps_0x11020000_40.dfu
  ramps_0x01020200_26_0x01.dfu  ramps_0x11020100_40.dfu
  ramps_0x01020200_26.dfu       ramps_0x31010000_40.dfu
  ramps_0x01020200_40_0x01.dfu  ramps_0x31010100_40.dfu
  ramps_0x01020200_40_0x02.dfu  ramps_0x41020000_40.dfu

  But it still doesn't work :(

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: bluetooth 4.101-0ubuntu13.1
  ProcVersionSignature: Ubuntu 3.19.0-25.26~14.04.1-generic 3.19.8-ckt2
  Uname: Linux 3.19.0-25-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.14.1-0ubuntu3.19
  Architecture: amd64
  CurrentDesktop: LXDE
  Date: Sat Dec 26 09:05:33 2015
  InstallationDate: Installed on 2015-11-14 (41 days ago)
  InstallationMedia: Lubuntu 14.04.3 LTS "Trusty Tahr" - Beta amd64 (20150805)
  InterestingModules: rfcomm bnep btusb bluetooth
  PackageArchitecture: all
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-25-generic root=UUID=5dd37748-b279-4351-861a-c7a3dfcc947e ro noprompt quiet splash vt.handoff=7
  SourcePackage: bluez
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 01/16/2015
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: G551JW.202
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: G551JW
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrG551JW.202:bd01/16/2015:svnASUSTeKCOMPUTERINC.:pnG551JW:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnG551JW:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.name: G551JW
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.
   hci0:	Type: BR/EDR  Bus: USB
   	BD Address: DC:85:DE:F7:D2:8A  ACL MTU: 1022:8  SCO MTU: 183:5
   	RX bytes:666 acl:0 sco:0 events:46 errors:0
   	TX bytes:1028 acl:0 sco:0 commands:46 errors:0

To manage notifications about this bug go to: