← Back to team overview

kernel-packages team mailing list archive

[Bug 1531768] Re: kernel 4.2/wily on arm64 and multiple CPUs is unusably slow


I tried to install the current xenial kernel
image-4.3.0-5-generic_4.3.0-5.16_arm64.deb). Package installation fails
due  to

  Processing triggers for initramfs-tools (0.120ubuntu6) ...
  update-initramfs: Generating /boot/initrd.img-4.3.0-5-generic
  Unsupported platform.
  run-parts: /etc/initramfs/post-update.d//flash-kernel exited with return code 1

but nevertheless I can boot with "reboot -f" (as a normal reboot hangs).
Now lxc fails on lxc-net:

Jan 07 10:03:15 lxd-armhf1w systemd[1]: Starting LXC network bridge setup...
Jan 07 10:03:16 lxd-armhf1w lxc-net[10651]: RTNETLINK answers: Operation not supported
Jan 07 10:03:16 lxd-armhf1w lxc-net[10651]: Failed to setup lxc-net.

particularly it fails on "ip link add dev lxcbr0 type bridge".

dmesg error for this:

[  199.168466] module x_tables: unsupported RELA relocation: 275
[  199.232020] module llc: unsupported RELA relocation: 275

which might be a regression in xenial's arm64 kernel or lxc needing to
be adjusted to it? Either way, this is a deal-breaker, so with the
xenial kernel I can't do much.

However, operations like "lxc list" work without the lxcbr0 bridge. They
still take several minutes, but I don't get the dmesg errors any more.

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  kernel 4.2/wily on arm64 and multiple CPUs is unusably slow

Status in linux package in Ubuntu:

Bug description:
  I created an 8 CPU arm64 instance on Canonical's Scalingstack (which I
  want to use for armhf autopkgtesting in LXD). I started with wily as
  that has lxd available (it's not yet available in trusty nor the PPA
  for arm64).

  However, pretty much any LXD task that I do (I haven't tried much
  else) on this machine takes unbearably long. A simple "lxc profile set
  default raw.lxc lxc.seccomp=" or "lxc list" takes several minutes.

  I see tons of

  [ 1020.971955] rcu_sched kthread starved for 6000 jiffies! g1095 c1094 f0x0
  [ 1121.166926] INFO: task fsnotify_mark:69 blocked for more than 120 seconds.

  in dmesg (the attached apport info has the complete dmesg).

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-22-generic 4.2.0-22.27
  ProcVersionSignature: User Name 4.2.0-22.27-generic 4.2.6
  Uname: Linux 4.2.0-22-generic aarch64
   total 0
   crw-rw---- 1 root audio 116,  1 Jan  7 09:18 seq
   crw-rw---- 1 root audio 116, 33 Jan  7 09:18 timer
  AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: arm64
  ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
  Date: Thu Jan  7 09:24:01 2016
   eth0      no wireless extensions.

   lo        no wireless extensions.

   lxcbr0    no wireless extensions.
   00:00.0 Host bridge [0600]: Red Hat, Inc. Device [1b36:0008]
    Subsystem: Red Hat, Inc Device [1af4:1100]
    Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
  Lsusb: Error: command ['lsusb'] failed with exit code 1: unable to initialize libusb: -99

   PATH=(custom, no user)

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-22-generic root=LABEL=cloudimg-rootfs earlyprintk
   linux-restricted-modules-4.2.0-22-generic N/A
   linux-backports-modules-4.2.0-22-generic  N/A
   linux-firmware                            1.149.3
  RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to: