← Back to team overview

kernel-packages team mailing list archive

[Bug 1527354] Re: [Jawbone ERA] HFP features not working with Bluez5


Re-tested on krillin, rc-proposed #231.  Same result, my Jawbone only
works as a headset.  Same result on arale ( rc-proposed, #220 ).  On
mako ( rc-proposed, #331 ) I couldn't even get the headset function to

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to bluez in Ubuntu.

  [Jawbone ERA] HFP features not working with Bluez5

Status in bluez package in Ubuntu:

Bug description:
  While debugging some re-factoring work on the ofono upower plugin, I
  noticed that I wasn't able to answer or terminate calls using my
  Jawbone ERA headset.  I bought this headset last year, and although
  it's an older model, it's spec sheet states that it supports HSP 1.1,
  and HFP 1.5.

  I can pair the device with my krillin, and it properly auto connects (
  note, this seems to work better than my iPhone ).   In-call audio
  works for both incoming and outgoing calls, however I get no ringtone
  in the headset and as mentioned above, I can't answer or terminate the
  call.   I've verified on my iPhone6, that the headset works.  In
  addition to a ringtone in the earpiece, the headset also announces the
  incoming phone number.

  From looking at the ofono debug output, I'm never seeing a new HFP
  connection occur.  I noticed as the upower plugin uses a foreach_atom
  (HFP) style call to update the battery indicators on all attached HFP

  I've tested this extensively on krillin, running rc-proposed:

  phablet@ubuntu-phablet:~$ system-image-cli -i
  current build number: 205
  device name: krillin
  channel: ubuntu-touch/rc-proposed/bq-aquaris.en
  last update: 2015-12-16 17:53:19
  version version: 205
  version ubuntu: 20151216
  version device: 20151204-2254a36
  version custom: 20151111--36-46-vivid

  I've also tested on mako, rc-proposed ( #317 ).

  For reference here's the versions of bluez, ofono, and PulseAudio on
  the device:

  bluez	            5.36-0ubuntu2~overlay1
  ofono              1.17.bzr6908+15.04.20151203-0ubuntu1~awe3
  pulseaudio	    1:6.0-0ubuntu9.11

To manage notifications about this bug go to: