← Back to team overview

kernel-packages team mailing list archive

[Bug 1536490] Re: rtl8821ae has no connectivity in 5GHz networks


Same problem after upgrading kernel to linux-image-4.2.0-27-generic.
Works fine with 4.2.0-25. On home router this time (have not tried at
work - I do not plan on taking this laptop to work):

1) Manufacturer

2) Model

3) Firmware Version

You received this bug notification because you are a member of Kernel
Packages, which is subscribed to linux in Ubuntu.

  rtl8821ae has no connectivity in 5GHz networks

Status in linux package in Ubuntu:

Bug description:
  Seems to be the same as

  Lenovo Ideapad 300 (80Q7008EAU - 15.6" i5 8Gb 1TB) on fresh install of
  amd64 Wily/15.10. Wifi worked ok under Windows 10 home that came with

  rtl8821ae driver loaded. Connected to AP fine. Got IP address, GW, DNS
  etc correctly, but no traffic.

  Workaround worked fine:
  git clone https://github.com/lwfinger/rtlwifi_new.git
  cd rtlwifi_new
  sudo make install
  sudo restart now

  FWIW, proper 802.11ac speeds copying large files.

  Same problem after apt-get upgrade installed linux-
  image-4.2.0-25-generic. make installed the above driver again and all

  ProblemType: Bug
  DistroRelease: Ubuntu 15.10
  Package: linux-image-4.2.0-25-generic 4.2.0-25.30
  ProcVersionSignature: Ubuntu 4.2.0-25.30-generic 4.2.6
  Uname: Linux 4.2.0-25-generic x86_64
  ApportVersion: 2.19.1-0ubuntu5
  Architecture: amd64
   /dev/snd/controlC0:  si         1379 F.... pulseaudio
  CurrentDesktop: XFCE
  Date: Thu Jan 21 17:25:45 2016
  HibernationDevice: RESUME=UUID=ccc3ab01-94d8-4d55-89b4-21ece100a3d6
  InstallationDate: Installed on 2016-01-21 (0 days ago)
  InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 004: ID 0bda:0821 Realtek Semiconductor Corp. 
   Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
   Bus 001 Device 002: ID 174f:14e9 Syntek 
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: LENOVO 80Q7
  ProcFB: 0 inteldrmfb
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.2.0-25-generic.efi.signed root=UUID=cab1a31f-1f61-43e6-a6e7-2edc12bb048d ro quiet splash vt.handoff=7
   linux-restricted-modules-4.2.0-25-generic N/A
   linux-backports-modules-4.2.0-25-generic  N/A
   linux-firmware                            1.149.3
  SourcePackage: linux
  UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 08/13/2015
  dmi.bios.vendor: LENOVO
  dmi.bios.version: D5CN28WW
  dmi.board.asset.tag: NO Asset Tag
  dmi.board.name: Paris 5A8
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40700 WIN
  dmi.chassis.asset.tag: NO Asset Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo ideapad 300-15ISK
  dmi.modalias: dmi:bvnLENOVO:bvrD5CN28WW:bd08/13/2015:svnLENOVO:pn80Q7:pvrLenovoideapad300-15ISK:rvnLENOVO:rnParis5A8:rvrSDK0J40700WIN:cvnLENOVO:ct10:cvrLenovoideapad300-15ISK:
  dmi.product.name: 80Q7
  dmi.product.version: Lenovo ideapad 300-15ISK
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to: